Bug 441003 - pyconfig-32.h incorrectly sets #define HAVE_STROPTS_H 1
Summary: pyconfig-32.h incorrectly sets #define HAVE_STROPTS_H 1
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python   
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: James Antill
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-04 22:23 UTC by Michael Young
Modified: 2008-04-08 05:25 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-08 05:25:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Young 2008-04-04 22:23:18 UTC
The file /usr/include/python2.5/pyconfig-32.h includes the line
#define HAVE_STROPTS_H 1
Due to recent changes to glibc this is no longer true, which means that
compiling programs that use python can fail. Probably python needs to be rebuilt.

Comment 1 James Antill 2008-04-08 05:24:58 UTC
 Yeh, seems like glibc has just removed that file.
 Well I bumped the release and rebuilt ... which I assume will solve this.



Note You need to log in before you can comment on or make changes to this bug.