Bug 441007 - Partitionning and 'First-boot' user creation screens are not fully translated in French in FC9Beta1
Partitionning and 'First-boot' user creation screens are not fully translated...
Status: CLOSED NEXTRELEASE
Product: Fedora Localization
Classification: Fedora
Component: French [fr] (Show other bugs)
unspecified
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Thomas Canniot
Alain Portal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-04 19:53 EDT by Eddahbi Karim
Modified: 2009-09-21 17:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-08 14:09:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eddahbi Karim 2008-04-04 19:53:53 EDT
Description of problem:

Some parts of the partition creation screen aren't actually translated in the
installation process of the Installation DVD for x86_64 systems.
For examples :
* The dropdown menu in the partition method selection, the user cand read,
between other options translated in French :
"Resize existing partition and create default layout in free space".
I think it could be replaced by "Redimensionner les partitions existantes et
créer un agencement par défaut dans l'espace libre." but it's a literal translation.
* The user can read 'Encrypt system' at the left of a checkbox.
* The title of the second section of this screen is :
"What drive would you like to boot the installation from ?" which could be
translated by "Depuis quel disque, voulez-vous démarrer l'installation ?"

Concerning the 'user creation' step in the First Boot Process, it isn't
translated at all.

Version-Release number of selected component (if applicable):

Fedora Core 9 Beta 1

How reproducible:

Always with the installation DVD of Fedora Core 9 Beta 1, when selecting French
language, at the second screen of the installation

Steps to Reproduce:
1. Begin the installation process of Fedora Core 9 Beta 1 from the x86_64
Installation DVD
2. Select 'Français' as language when asked, at the second screen of the installer.

Actual results:

See the description of the problem

Expected results:

These interfaces, and other ones, in the installer and first-boot process, fully
translated in French.

Additional info:

None
Comment 1 Thomas Canniot 2008-04-05 05:23:23 EDT
Anaconda was not fully translated when 9 beta went out. 

It is now : https://translate.fedoraproject.org/module/anaconda#master

You should check if there are still translation problems with the latest rawhide
snapshot available from : http://torrent.fedoraproject.org/

Thanks
Comment 2 Eddahbi Karim 2008-04-05 08:36:20 EDT
Well, I tried the last Live-DVD (2008-04-04) for x86_64.

First, it didn't start with french locales. I had to execute the following
command to make it work :

[fedora@localhost ~]$ LANG=C liveinst --lang=fr_FR
FATAL: Module md not found.
  0 logical volume(s) in volume group "Fedora" now active
Probing for video card:   nVidia Corporation GeForce 8600M GT
15:06:02 Starting graphical installation...

Without the definition of the locale (LANG=...), liveinst starts then crashes
before showing the first step of the installer.
Examples :
---

$ LANG=fr_FR.utf8 liveinst 
FATAL: Module md not found.
  0 logical volume(s) in volume group "Fedora" now active
Traceback (most recent call last):
  File "/usr/sbin/anaconda", line 869, in <module>
    probeHW(opts, x_already_set, xserver)
  File "/usr/sbin/anaconda", line 456, in probeHW
    xserver.probeHW(forceDriver=opts.xdriver)
  File "/usr/lib64/python2.5/site-packages/rhpxl/xserver.py", line 91, in probeHW
    cardstr = _("Probing for video card:   %s") % (cardstr,)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 1: ordinal
not in range(128)

--

$ liveinst --lang=fr_FR
FATAL: Module md not found.
  0 logical volume(s) in volume group "Fedora" now active
Traceback (most recent call last):
  File "/usr/sbin/anaconda", line 869, in <module>
    probeHW(opts, x_already_set, xserver)
  File "/usr/sbin/anaconda", line 456, in probeHW
    xserver.probeHW(forceDriver=opts.xdriver)
  File "/usr/lib64/python2.5/site-packages/rhpxl/xserver.py", line 91, in probeHW
    cardstr = _("Probing for video card:   %s") % (cardstr,)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 1: ordinal
not in range(128)

--

$ LANG=C liveinst --lang=fr_FR
FATAL: Module md not found.
  0 logical volume(s) in volume group "Fedora" now active
Probing for video card:   nVidia Corporation GeForce 8600M GT
15:06:02 Starting graphical installation...

---

Now about the translation itself :
All the problems spotted in Fedora Core 9 Beta 1 installer weren't spotted in
the Rawhide 2008-04-04.

The only problem spotted could be an anaconda bug but i'm not sure :
* When the installer claims that there's not enough disk space to copy the image
on the root partition, the button 'Précédent' leads to the copy of the image,
which is weird because it just told me it couldn't done it (And it crashed at
the end...).
Does the bug comes from anaconda or is it an erroneous translation of the button ?
Comment 3 Thomas Canniot 2008-04-05 11:41:06 EDT
> First, it didn't start with french locales. I had to execute the following
> command to make it work

I could reproduce this but this bug is not the proper place to report this
problem. Against anaconda or against the LiveCD component, i don't know.


> Does the bug comes from anaconda or is it an erroneous translation of the button ?

Could you launch the liveinst in english then and look at the original
description of the button please ? I'm not sure to know where you encounter the
problem.

Thanks
Comment 4 Thomas Canniot 2008-04-06 04:30:34 EDT
I created bug #441053
Comment 5 Piotr Drąg 2008-11-08 14:09:44 EST
Anaconda and firstboot French translations in master branch are completed. Closing.

Note You need to log in before you can comment on or make changes to this bug.