Bug 441009 - First boot ignores the keyboard layout selected in the installer, used by the system in the console and used the English one in Fedora Core 9 Beta 1
First boot ignores the keyboard layout selected in the installer, used by the...
Status: CLOSED DUPLICATE of bug 438246
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
rawhide
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-04 20:19 EDT by Eddahbi Karim
Modified: 2008-04-07 11:01 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 11:01:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eddahbi Karim 2008-04-04 20:19:40 EDT
Description of problem:

When 'firstboot' is executed after a reboot following the installation of Fedora
Core 9 Beta 1, using the french keyboard layout during the installation process,
it's using the English keyboard layout and not the French one.
This is weird because, when I had to type the passphrase to decrypt my root
partition, I did it using the french keyboard layout.

The problem is present in X11 too, after configuring the system with firstboot
so the problem could be hidden to the user until it loads its session.

Version-Release number of selected component (if applicable):

Fedora Core 9 Beta 1, Installation DVD, X86_64, networkless installation.

How reproducible:

Actually, tried it only once.

Steps to Reproduce:
1. Install Fedora Core 9 Beta 1 with the installation DVD designed for X86_64
architectures.
2. During the installation, choose the French latin9 keyboard layout and type
your password using the French layout.
3. After the installation, reboot, wait for Firstboot to come and try to input
'qsdf' in text-areas where the text isn't masked (IE : not password textareas !)
.

Actual results:

If you got a French keyboard, you'll see 'asdf' printed in the text-area
selected, indicating that the keyboard layout currently used is the English one,
not the French one.

Expected results:

The characters input in the text-area MUST be 'qsdf'. It's important, at this
point of the installation to have a correct keyboard layout since you'll input
the password used by the principal user account !
If the layout is wrong, you'll input a different password that you think you've
input !

Additional info:
None
Comment 1 Rolf Linder 2008-04-06 09:47:31 EDT
same issue here....made installations of fedora 9 beta 1 on i386 arch and also
on x64_86 architecutre...both version do have this problem.

when you select a keyboard-layout while installing, this is not configured after
the reboot to your system. you have to setup manually again your keyboard layout...
Comment 2 Chris Lumens 2008-04-07 09:35:12 EDT
I think this was due to using evdev as opposed to the older keyboard driver. 
Can you test either the weekly snapshot releases or rawhide and let me know if
this is still broken?  Thanks.
Comment 3 Chris Lumens 2008-04-07 11:01:05 EDT
Looks like this one is still around.

*** This bug has been marked as a duplicate of 438246 ***

Note You need to log in before you can comment on or make changes to this bug.