Bug 441017 - LaTeX rendering nonfunctional in Inkscape 0.46.
LaTeX rendering nonfunctional in Inkscape 0.46.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: inkscape (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-05 00:48 EDT by August Schwerdfeger
Modified: 2009-01-07 13:10 EST (History)
3 users (show)

See Also:
Fixed In Version: 0.46-2.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-22 18:42:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description August Schwerdfeger 2008-04-05 00:48:31 EDT
The mechanism for rendering LaTeX objects (Effects->Render->LaTeX Formula)
appears to be broken in Inkscape 0.46.

In version 0.45 the renderer worked as expected. However, I started the new
version after the upgrade and without doing anything else attempted to render a
LaTeX formula, which proved impossible: while the renderer ran normally, the
rendered formula did not show up.

Several formulae were tried, with identical (non-)results. Erroneous formulae
were tried, with the renderer reporting the error as expected. I then removed
version 0.46 and reverted to version 0.45, which is once again working as expected.
Comment 1 Lubomir Kundrak 2008-04-05 17:34:12 EDT
Fixed in inkscape-0.46-2.fc8. Do you think this should be fixed in an update? I
tend to think yes, as it is more-or-less a regression (LaTeX support was also
partly broken in 0.45 though, see bug #252159), so I'll push that to testing
once it builds.
Comment 2 Fedora Update System 2008-04-05 18:11:08 EDT
inkscape-0.46-2.fc8 has been submitted as an update for Fedora 8
Comment 3 Fedora Update System 2008-04-09 01:12:44 EDT
inkscape-0.46-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update inkscape'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2890
Comment 4 Jef Spaleta 2008-04-17 19:56:28 EDT
inkscape-0.46-2.fc8  has broken pdf rendering.

artifacts in the output when transparency or gradient effects are used.

downgrading to inkscape-0.46-1.fc8 and i get usable pdf rendering again.

-jef
Comment 5 Lubomir Kundrak 2008-04-18 03:33:58 EDT
Jef: That is very strange, since the only change between the releases was this
patch [1]. I am wondering if there was some change in its build-time
dependencies or something. Could you please provide a test case, such as svg
file whose rendering to pdf differs between the versions of inkscape in question?

[1]
http://cvs.fedoraproject.org/viewcvs/rpms/inkscape/F-8/inkscape-0.46-fixlatex.patch?view=markup

Thanks!
Comment 6 Jef Spaleta 2008-04-18 14:04:26 EDT
It was a bit odd...I certainly didn't expect it.

Even better I can't reproduce it today...even with the svg that was repeatably
problematic earlier.  Oh well.  Sorry to bother you.

-jef
Comment 7 Fedora Update System 2008-04-22 18:42:38 EDT
inkscape-0.46-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.