Bug 441023 - mkinitrd uses incorrect device name for encrypted swap
mkinitrd uses incorrect device name for encrypted swap
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
i386 Linux
low Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-05 02:57 EDT by Stefan Becker
Modified: 2008-08-02 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version: mkinitrd-6.0.43-1.fc9.i386
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 13:15:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Becker 2008-04-05 02:57:10 EDT
Description of problem:

This is a followup to bug #441001

mkinitrd doesn't use the correct device name when the swap is encrypted. Here
are the changes I had to make to the init script in order to get hibernation
working:

 echo Setting up disk encryption: /dev/mapper/VolGroup00-LogVol01
 cryptsetup luksOpen /dev/mapper/VolGroup00-LogVol01 luks-VolGroup00-LogVol01
-resume mapper/luks-VolGroup00-LogVol01
+resume /dev/mapper/luks-VolGroup00-LogVol01
 echo Creating root device.

i.e. the leading "/dev/" is missing.

If this gets fixed it looks like that Fedora 9 encrypted disk support will be
ready. Yeah!

Version-Release number of selected component (if applicable):
mkinitrd-6.0.41-1.fc9.i386
Comment 1 Peter Jones 2008-04-07 10:58:16 EDT
Do you still see this in 6.0.42 ?
Comment 2 Stefan Becker 2008-04-07 13:15:52 EDT
Retried with 

   mkinitrd-6.0.43-1.fc9.i386

Works OK now. Thanks

Note You need to log in before you can comment on or make changes to this bug.