Bug 441043 - Anaconda crashes trying to modify an already existing partition
Anaconda crashes trying to modify an already existing partition
Status: CLOSED DUPLICATE of bug 441244
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: parted (Show other bugs)
5.1
x86_64 Linux
low Severity high
: rc
: ---
Assigned To: Joel Andres Granados
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-05 09:22 EDT by Arnaud Gomes-do-Vale
Modified: 2008-08-27 16:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-27 16:37:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda crash report. (1.16 MB, text/plain)
2008-04-05 09:22 EDT, Arnaud Gomes-do-Vale
no flags Details

  None (edit)
Description Arnaud Gomes-do-Vale 2008-04-05 09:22:00 EDT
Description of problem:

Anaconda crashes after computing package dependencies and before creating the
file systems.

Version-Release number of selected component (if applicable):

Tried with the CentOS 5.0, CentOS 5.1, Scientific Linux 5.0 and Fedora 8
boot.iso images.

How reproducible:

Always.

Steps to Reproduce:
1. boot on install CD
2. select HTTP as the installation method
3. select an existing ext3 partition to be formatted and used as /, don't touch
other partitions
4. select software to install
5. wait for anaconda to crash
  
Actual results:

Error: Error informing the kernel about modifications to partition /dev/sdb5 --
Périphérique ou ressource occupé.

Expected results:

Install a new system on /dev/sdb2 -- /dev/sdb5 should not even be touched by the
installer, it is /home for the existing Fedora system.

Additional info:

I already have a Fedora install on this machine. / is /dev/sdb3 ; /dev/sda1,
/dev/sdb5, /dev/sdb6 are also used as ext3 file systems ; /dev/sdb1 is swap.
Comment 1 Arnaud Gomes-do-Vale 2008-04-05 09:22:00 EDT
Created attachment 301367 [details]
Anaconda crash report.
Comment 2 Arnaud Gomes-do-Vale 2008-05-17 13:28:10 EDT
The error message is still here in Fedora 9, but it does not kill Anaconda anymore.
Comment 3 Joel Andres Granados 2008-06-10 08:43:33 EDT
Can you please test with current rhel52 or centos 52 to see if the bug is still
present in the 52 distro.
btw, what was the partition that was present in the disk before installation (if
you have it, please do a fdisk -l DEVICE and a parted DEVICE print)
Comment 4 Arnaud Gomes-do-Vale 2008-06-23 15:11:52 EDT
The bug is still present in CentOS 5.2.

fdisk complains about partitions not ending on cylinder boundaries; however, I
never did any advanced partition manipulation on this drive, I just created and
deleted partitions with anaconda or fdisk itself.


[root@carrosse ~]# fdisk -l /dev/sdb

Disk /dev/sdb: 81.9 GB, 81964302336 bytes
255 heads, 63 sectors/track, 9964 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0007e292

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1         244     1953472+  82  Linux swap / Solaris
Partition 1 does not end on cylinder boundary.
/dev/sdb2             245        1701    11703352+  83  Linux
/dev/sdb3   *        1703        3162    11719008   83  Linux
Partition 3 does not end on cylinder boundary.
/dev/sdb4            3162        9965    54651713    5  Extended
Partition 4 does not end on cylinder boundary.
/dev/sdb5            3162        4377     9765976+  83  Linux
/dev/sdb6            4377        9965    44885704+  83  Linux
[root@carrosse ~]# parted /dev/sdb print
Model: ATA Maxtor 6Y080M0 (scsi)
Disk /dev/sdb: 82.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type      File system  Flags
 1      32.3kB  2000MB  2000MB  primary   linux-swap        
 2      2007MB  14.0GB  12.0GB  primary                     
 3      14.0GB  26.0GB  12.0GB  primary   ext3         boot 
 4      26.0GB  82.0GB  56.0GB  extended                    
 5      26.0GB  36.0GB  10.0GB  logical   ext3              
 6      36.0GB  82.0GB  46.0GB  logical   ext3              

 
Comment 5 Joel Andres Granados 2008-07-28 17:07:35 EDT
The list that parted spits out seems sane.  The message that is stated in
comment #1 is usually hit with partprobe.  Can you try `partprobe /dev/sda`  and
see if it blows up?  We have had some problems with partprobe before, but
nothing related to x86_64.
Comment 6 Arnaud Gomes-do-Vale 2008-07-28 17:21:11 EDT
I have trouble installing on sdb, not sda.

[root@carrosse ~]# partprobe /dev/sda
[root@carrosse ~]# partprobe /dev/sdb
Error: Error informing the kernel about modifications to partition /dev/sdb4 --
Device or resource busy.  This means Linux won't know about any changes you made
to /dev/sdb4 until you reboot -- so you shouldn't mount it or use it in any way
before rebooting.
Warning: The kernel was unable to re-read the partition table on /dev/sdb
(Device or resource busy).  This means Linux won't know anything about the
modifications you made until you reboot.  You should reboot your computer before
doing anything with /dev/sdb.
Comment 7 Joel Andres Granados 2008-08-27 16:37:17 EDT
I see that the message you got is related to sdb4, the extended partition.  I addressed this same issue in bug 441244.  I'll dup this one as the other is already in qa queue.  Please retest with 5.3 and reopen if the issue is still there.

*** This bug has been marked as a duplicate of bug 441244 ***

Note You need to log in before you can comment on or make changes to this bug.