Bug 441046 - Crash when clicking "sound" button
Crash when clicking "sound" button
Status: CLOSED DUPLICATE of bug 440299
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-05 09:32 EDT by Mary Ellen Foster
Modified: 2008-04-05 09:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-05 09:39:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mary Ellen Foster 2008-04-05 09:32:27 EDT
Description of problem:
In systemsettings, if I click on "sound" the whole settings window exits. Here's
what it prints before it dies:

systemsettings(15141) MainWindow::selectionChanged: Selected item:  "Sound"
systemsettings(15141) MainWindow::selectionChanged: Comment:        "Sound
System Configuration"
systemsettings(15141)/kutils (KCModuleProxy) KCModuleProxyPrivate::loadModule:
Module not already loaded, loading module  "Sound"  from library  "kcm_phonon" 
using symbol  "kcm_phonon"
systemsettings(15141)/phonon (xine backend) Phonon::Xine::Backend::Backend:
setting xine verbosity to 0
systemsettings(15141)/phonon (xine backend) Phonon::Xine::Backend::Backend:
Using Xine version  1.1.11.1
systemsettings(15141) Phonon::KdePlatformPlugin::createBackend: using backend: 
"Xine"
systemsettings(15141)/phonon (xine backend)
Phonon::Xine::XineEngine::checkAudioOutputs: isEmpty
systemsettings(15141)/phonon (audiodevicelist)
Phonon::AudioDeviceEnumeratorPrivate::findVirtualDevices:
"iec958:CARD=Intel,DEV=0"  doesn't work.
systemsettings(15141)/phonon (xine backend)
Phonon::Xine::XineEngine::checkAudioOutputs: outputPlugin:  alsa
systemsettings(15141)/phonon (audiodevicelist)
Phonon::AudioDeviceEnumerator::availablePlaybackDevices: (
- "HDA Intel (ALC883 Analog)" OSS ("/dev/dsp") index: 1 preference: 35 avail:
true advanced: false  ,
- "HDA Intel (ALC883 Analog)" ALSA ("x-phonon:CARD=0,DEV=0",
"plughw:CARD=0,DEV=0") index: 2 preference: 36 avail: true advanced: false  ,
- "HDA Intel (ALC883 Analog)" OSS ("/dev/audio") index: 1 preference: 35 avail:
true advanced: false  ,
- "HDA Intel, ALC883 Analog (Front speakers)" ALSA ("front:CARD=Intel,DEV=0")
index: 3 preference: 30 avail: true advanced: true  ,
- "PulseAudio Sound Server" ALSA ("pulse") index: 5 preference: 30 avail: true
advanced: false  ,
- "Default" ALSA ("default") index: 6 preference: 1000 avail: true advanced:
false  ,
- "ALSA Default Device" ALSA ("default") index: 6 preference: 1000 avail: true
advanced: false  )
systemsettings(15141)/phonon (xine backend)
Phonon::Xine::XineEngine::checkAudioOutputs: outputPlugin:  oss
systemsettings(15141)/phonon (xine backend)
Phonon::Xine::XineEngine::checkAudioOutputs: outputPlugin:  arts
systemsettings(15141)/phonon (xine backend)
Phonon::Xine::XineEngine::checkAudioOutputs: outputPlugin:  file
systemsettings(15141)/phonon (xine backend)
Phonon::Xine::XineEngine::checkAudioOutputs: outputPlugin:  none
systemsettings(15141)/phonon (xine backend)
Phonon::Xine::XineEngine::checkAudioOutputs: 6 "Default" "alsa" ("default")
systemsettings(15141)/phonon (xine backend)
Phonon::Xine::XineEngine::checkAudioOutputs: 6 "ALSA Default Device" "alsa"
("default")
systemsettings(15141)/phonon (xine backend)
Phonon::Xine::XineEngine::checkAudioOutputs: 2 "HDA Intel (ALC883 Analog)"
"alsa" ("x-phonon:CARD=0,DEV=0", "plughw:CARD=0,DEV=0")
systemsettings(15141)/phonon (xine backend)
Phonon::Xine::XineEngine::checkAudioOutputs: 5 "PulseAudio Sound Server" "alsa"
("pulse")
systemsettings(15141)/phonon (xine backend)
Phonon::Xine::XineEngine::checkAudioOutputs: 3 "HDA Intel, ALC883 Analog (Front
speakers)" "alsa" ("front:CARD=Intel,DEV=0")
systemsettings(15141)/phonon (xine backend)
Phonon::Xine::XineEngine::checkAudioOutputs: 10000 "aRts" "arts" ()
systemsettings(15141)/kutils (KCModuleProxy) KCModuleProxyPrivate::loadModule:
Module not already loaded, loading module  "Phonon Xine"  from library 
"kcm_phononxine"  using symbol  "kcm_phononxine"
ASSERT: "deinterlacer" in file
/builddir/build/BUILD/kdebase-runtime-4.0.3/phonon/xine/kcm/xineoptions.cpp, line 63

Version-Release number of selected component (if applicable):
kdebase-workspace-4.0.3-6.fc9.i386
Comment 1 Kevin Kofler 2008-04-05 09:39:25 EDT

*** This bug has been marked as a duplicate of 440299 ***

Note You need to log in before you can comment on or make changes to this bug.