Bug 441047 - 1-wire drivers not built in kernel
1-wire drivers not built in kernel
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-05 09:33 EDT by Pierre Ossman
Modified: 2008-04-29 16:54 EDT (History)
0 users

See Also:
Fixed In Version: 2.6.24.5-85.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-29 16:54:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierre Ossman 2008-04-05 09:33:51 EDT
The 1-wire drivers are for some odd reason not built in Fedora kernels. Could
those please be included?
Comment 1 Dave Jones 2008-04-05 13:58:43 EDT
I think they weren't enabled basically because nothing was using them.

Oh, that was it.. there was some conflict with the matrox w1 driver and the
matrox framebuffer driver iirc, because only one of them could register the PCI
device successfully.

afaik, we still don't support multiple drivers for a single pci device.

The other W1 drivers are probably safe to enable though.
Comment 2 Pierre Ossman 2008-04-05 14:35:40 EDT
The w1 thermal devices expose a sysfs interface, so they are useful for anyone
with a shell. :)

So please enable in a not too far away F8 update.
Comment 3 Chuck Ebbert 2008-04-07 00:38:25 EDT
In F8 2.6.24.4-75 and also in rawhide (without the Matrox driver.)
Comment 4 Pierre Ossman 2008-04-14 13:07:08 EDT
Any plans for a new build for F8?
Comment 5 Fedora Update System 2008-04-22 18:42:55 EDT
kernel-2.6.24.5-85.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-3260
Comment 6 Fedora Update System 2008-04-29 16:54:13 EDT
kernel-2.6.24.5-85.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.