Bug 441050 - network stops appearing even when available
network stops appearing even when available
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
8
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-05 10:11 EDT by Chris Ward
Modified: 2008-04-10 07:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-10 07:24:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ward 2008-04-05 10:11:04 EDT
Description of problem:
It doesn't seem as though i've updated the NetworkManager package any time
recently, but all of the sudden it's having trouble seeing my wireless network.
Something has changed. 

Before a few days ago, I would simply turn on my computer a nm would find my
network, ask me for my password, and connect. No problems. Now though, often
times when i boot up and log into gnome, nm finds all of the networks in the
area except mine!

I can always manually "connect to another network" just fine, by typing in the
name of my network, but it more and more often doesn't find the network on it's own.

Also, the issue often occurs now after i've suspended my laptop (Lenovo T61) and
it wakes back up. Even after i manually choose it, it disappears. But before a
few days ago this simply wasn't the case. So i have to manually "connect to
another network" again.

The only change I've made (consciously), and this is way out there to be the
cause of it, was to add Amarok to the Session Startup process. Before a few days
ago i really wasn't using my laptop to listen to music...but i've started to use
amarok in the past days on a daily basis (i've had it installed for months
though and used it before but not often...) and now i'm having these issues. But
even when i don't startup with Amarok now, it still doesn't find/list my network
among the others. So really, i doubt that's the cause, but who knows! 

I'll be trying a few other things, to see if i can't pinpoint where the problem
arises. 

If there is any information I can give, or things I could do to get more
informaiton, please let me know. I would love to resolve this issue asap.


%>grep -H NetworkManager rpmpkgs
rpmpkgs:NetworkManager-0.7.0-0.6.7.svn3235.fc8.i386.rpm
rpmpkgs:NetworkManager-glib-0.7.0-0.6.7.svn3235.fc8.i386.rpm
rpmpkgs:NetworkManager-gnome-0.7.0-0.6.7.svn3235.fc8.i386.rpm
rpmpkgs:NetworkManager-openvpn-0.7.0-8.svn3302.fc8.i386.rpm
rpmpkgs:NetworkManager-vpnc-0.7.0-0.6.3.svn3109.fc8.i386.rpm

%> grep iw /var/log/dmesg 
iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux,
1.2.26kds
iwl3945: Copyright(c) 2003-2008 Intel Corporation
iwl3945: Detected Intel Wireless WiFi Link 3945ABG
iwl3945: Tunable channels: 13 802.11bg, 23 802.11a channels
phy0: Selected rate control algorithm 'iwl-3945-rs'

%> uname -r
2.6.24.3-50.fc8
Comment 1 Chris Ward 2008-04-06 06:26:04 EDT
Okay, so after a bit more playing around, it seems the whole amarok connection
is only coincidence. It seems the issue spawns more generally from when I
suspend to ram in general. However, I must say, strangely, it does appear that
when i start Amarok, the problem seems to occur more quickly than when I do not. 

In otherwords. I start up F7. Log in, and my network is found immediately. I log
in to the network. If i start amarok, then suspend to ram and wake it up, my
wireless network missing immediately. Otherwise, without having already started
amarok, I can wake it up, and my net will still be available, but if i then put
it back to sleep and wake it again, it will be gone. 

Sometimes only my wireless net is missing, while NM still picks up others in the
area. Other times NM picks up no networks at all, even when before there was a
list of 3 or 4, including my own. 

I have no idea how to "reset" NM, so i either have to manually "connect to other
network"  or hard-restart the system. I've tried killing NM and relaunching it,
but that doesn't appear to work, since after restarting it my network still
doesn't reappear. 

Comment 2 Chris Ward 2008-04-06 06:54:50 EDT
More troubles. After a while, a few manual connects that is (cause i really
don't want to restart each time this happens), i'm unable even to use the manual
"connect to other network" method for connecting. It doesn't accept my password
anymore. 

I've found that I need to kill the running NetworkManager command, and restart
it, then, even though it doesn't find my network automatically, i can atleast
connect manually once again.

Comment 3 Dan Williams 2008-04-08 12:35:09 EDT
when you run into this issue, does:

rmmod iwl3945
modprobe iwl3945

help at all?  If so, it's most certainly a driver issue.
Comment 4 Chris Ward 2008-04-10 07:24:00 EDT
Yes, that does appear to help. Closing. Moving bug to kernel space :-)
Comment 5 Chris Ward 2008-04-10 07:53:13 EDT
I'm finding actually that it might just be my absolute impatience with the
re-connect speed causing this 'bug'. Upon resuming from suspend, after some more
testing, and waiting, it seems eventually the network is found, but usually it
takes 30 seconds or more. I would expect it to find it immediately, or within a
few seconds anyway. I can manually connect faster than this! :-)

So perhaps i should file a new bug again NetworkManager to attempt to
immediately try to manually reconnect to the same network as was previously
connected to when resuming from suspend, rather than searching for new networks
and attempting to connect only after the search process has completed...what do
you think?

Note You need to log in before you can comment on or make changes to this bug.