Bug 441055 - Initial mixer settings are incorrect for Intel sound card
Initial mixer settings are incorrect for Intel sound card
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: alsa-utils (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-05 12:28 EDT by Mary Ellen Foster
Modified: 2008-05-17 09:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-17 09:38:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My initial mixer settings as shown by kmix (29.03 KB, image/png)
2008-04-05 12:28 EDT, Mary Ellen Foster
no flags Details

  None (edit)
Description Mary Ellen Foster 2008-04-05 12:28:37 EDT
Description of problem:
(This may be a problem with some component other than alsa ...)

The initial mixer settings on my laptop have two things labelled "front", one of
which is muted and set to zero. This means that I don't have any sound until I
turn it up. I'll attach a screenshot of kmix.

This is with the onboard Intel sound on a laptop; lspci says it's a "Intel
Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)".

Note that this is new since the beta, as I did have sound from the start with
the F9 beta live image (KDE) but I don't have sound with the 20080404 rawhide
snapshot.

Version-Release number of selected component (if applicable):
alsa-lib-1.0.16-3.fc9.i386
Comment 1 Mary Ellen Foster 2008-04-05 12:28:37 EDT
Created attachment 301378 [details]
My initial mixer settings as shown by kmix
Comment 2 Martin Stransky 2008-04-17 08:12:20 EDT
Well, sound setting is now managed by pulse audio. Reassigning....
Comment 3 Lennart Poettering 2008-04-23 18:03:32 EDT
Uh. Sensible initial initialization of the audio device is going to stay
something that should happen outside of PA.

Right now we have this awful alsaunmute script which tries to initialize the
sound card mixer properly in some way and is run form udev when a new device is
found. It doesn't do a good job with it.

PA will svae and restore volumes. But only of the Master slider. All other
controls are expected to be initialized by "alsactl init" in the future.

Please also read this huge thread:

http://mailman.alsa-project.org/pipermail/alsa-devel/2008-April/007071.html

In short: Yes, we know that the mixer is configured pretty badly by default
these days. It's going to improve. But it is unlikely to improve so much that we
find good defaults for all people by default.
Comment 4 Martin Stransky 2008-05-06 03:13:20 EDT
Can you attach on output of "amixer" console utility?
Comment 5 Bug Zapper 2008-05-14 04:56:48 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Mary Ellen Foster 2008-05-17 09:38:32 EDT
Here's the output, for posterity ... but now that I've installed the final
version of Fedora 9, this seems no longer to be an issue in any case.


Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65536
  Mono:
  Front Left: Playback 65536 [100%] [on]
  Front Right: Playback 65536 [100%] [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 65536
  Front Left: Capture 0 [0%] [off]
  Front Right: Capture 0 [0%] [off]

Note You need to log in before you can comment on or make changes to this bug.