Bug 441099 - messages clipped when larger font size used
messages clipped when larger font size used
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: notification-daemon (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
: 432031 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-06 01:52 EDT by jmccann
Modified: 2015-01-14 18:20 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-06 23:51:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (41.51 KB, image/png)
2008-04-06 01:54 EDT, jmccann
no flags Details
possible fix (623 bytes, patch)
2008-04-06 01:57 EDT, jmccann
no flags Details | Diff

  None (edit)
Description jmccann 2008-04-06 01:52:11 EDT
The messages in the notification bubbles are clipped mid-character when a larger
font size is used.

This leads to very confusing messages such as:
"The AC power has been unplugged. The system is"

Filed upstream 2 years ago:
http://trac.galago-project.org/ticket/16
Comment 1 jmccann 2008-04-06 01:54:32 EDT
Created attachment 301409 [details]
screenshot
Comment 2 jmccann 2008-04-06 01:57:35 EDT
Created attachment 301410 [details]
possible fix

This seems to work for me.
Comment 3 Matthias Clasen 2008-04-06 10:37:27 EDT
There is a different patch in 
https://bugs.launchpad.net/ubuntu/+source/notification-daemon/+bug/40379/

here: http://launchpadlibrarian.net/13112348/notify.diff


Can we figure out which one is better/more correct and commit it before the
freeze ? Thanks.
Comment 4 jmccann 2008-04-06 22:42:06 EDT
Also, at least:
http://trac.galago-project.org/ticket/162
http://trac.galago-project.org/ticket/159
http://trac.galago-project.org/ticket/158
http://trac.galago-project.org/ticket/154

So, I've tested the patch from 162 (that Ubuntu uses) and it doesn't completely
solve the problem for me.  It is clearly correct though.  So I'll try both.
Comment 5 Matthias Clasen 2008-04-06 23:22:56 EDT
Sounds good to me.
Comment 6 jmccann 2008-04-06 23:51:19 EDT
Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=553165
Comment 7 Tim Waugh 2008-11-26 06:26:16 EST
*** Bug 432031 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.