Bug 441102 - gnome-session has too many dependencies [NEEDINFO]
gnome-session has too many dependencies
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gnome-session (Show other bugs)
All Linux
low Severity medium
: rc
: ---
Assigned To: Ray Strode [halfline]
Depends On:
  Show dependency treegraph
Reported: 2008-04-06 03:08 EDT by Miro Halas
Modified: 2014-06-03 08:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2014-06-03 08:36:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (fedora)

Attachments (Terms of Use)

  None (edit)
Description Miro Halas 2008-04-06 03:08:42 EDT
Please describe the problem:

See http://bugzilla.gnome.org/show_bug.cgi?id=525899

I am running network server (CentOS 5.1) that doesn't need sound, cd burning or
printing. When I uninstalled the applications that I do not required, it also
removed gnome-session (I have not realized that it is removing it). Once I
installed back gnome-session it showed me the following list of dependencies

 Package                 Arch       Version          Repository        Size
 gnome-session           i386       2.16.0-6.el5.centos  base              409
Installing for dependencies:
 cdrdao                  i386       1.2.1-2          base              441 k
 cdrecord                i386       9:2.01-10        base              590 k
 cups                    i386       1:1.2.4-11.14.el5_1.6  updates          
2.7 M
 dvd+rw-tools            i386       7.0-0.el5.3      base              114 k
 ghostscript             i386       8.15.2-9.1.el5_1.1  updates           5.9 M
 ghostscript-fonts       noarch     5.50-13.1.1      base              801 k
 gnome-media             i386       2.16.1-3.el5     base              2.4 M
 gnome-volume-manager    i386       2.15.0-4.el5     base              404 k
 gthumb                  i386       2.7.8-5.el5      base              1.9 M
 libgnomecups            i386       0.2.2-8          base               73 k
 libgnomeprint22         i386       2.12.1-9.el5     base              396 k
 libgnomeprintui22       i386       2.12.1-6         base              318 k
 mkisofs                 i386       9:2.01-10        base              596 k
 nautilus-cd-burner      i386       2.16.0-7.el5     base              482 k
 paps                    i386       0.6.6-17.el5     base               31 k

I am not sure if there is a way to fix this but I believe I should be able to
use my computer via Gnome GUI without having all these packages that I do not
require installed.

Steps to reproduce:
1. yum install gnome-session
2. see list of dependencies, it includes software for sound, printing and cd
burning which shouldn't be required

Actual results:
Unnecessary packages are installed that cannot be removed

Expected results:
I should be able to use Gnome without having to install packages for printing,
sound, or cd burning since I am using Gnome to access and manage my network

Does this happen every time?

Other information:
This was tested on CentOS 5.1 with Gnome 2.16
Comment 1 RHEL Product and Program Management 2014-03-07 08:55:25 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 2 RHEL Product and Program Management 2014-06-03 08:36:51 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.