Bug 441105 - Liveinst does not start with French locales
Liveinst does not start with French locales
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rhpxl (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-06 04:33 EDT by Thomas Canniot
Modified: 2013-01-09 23:39 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-08 15:28:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Canniot 2008-04-06 04:33:31 EDT
I tried the last Live-DVD (2008-04-04) for x86_64.

Liveinst didn't start with french locales. I had to execute the following
command to make it work :

[fedora@localhost ~]$ LANG=C liveinst --lang=fr_FR
FATAL: Module md not found.
  0 logical volume(s) in volume group "Fedora" now active
Probing for video card:   nVidia Corporation GeForce 8600M GT
15:06:02 Starting graphical installation...

Without the definition of the locale (LANG=...), liveinst starts then crashes
before showing the first step of the installer.
Examples :
---

$ LANG=fr_FR.utf8 liveinst 
FATAL: Module md not found.
  0 logical volume(s) in volume group "Fedora" now active
Traceback (most recent call last):
  File "/usr/sbin/anaconda", line 869, in <module>
    probeHW(opts, x_already_set, xserver)
  File "/usr/sbin/anaconda", line 456, in probeHW
    xserver.probeHW(forceDriver=opts.xdriver)
  File "/usr/lib64/python2.5/site-packages/rhpxl/xserver.py", line 91, in probeHW
    cardstr = _("Probing for video card:   %s") % (cardstr,)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 1: ordinal
not in range(128)

--

$ liveinst --lang=fr_FR
FATAL: Module md not found.
  0 logical volume(s) in volume group "Fedora" now active
Traceback (most recent call last):
  File "/usr/sbin/anaconda", line 869, in <module>
    probeHW(opts, x_already_set, xserver)
  File "/usr/sbin/anaconda", line 456, in probeHW
    xserver.probeHW(forceDriver=opts.xdriver)
  File "/usr/lib64/python2.5/site-packages/rhpxl/xserver.py", line 91, in probeHW
    cardstr = _("Probing for video card:   %s") % (cardstr,)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 1: ordinal
not in range(128)

--

$ LANG=C liveinst --lang=fr_FR
FATAL: Module md not found.
  0 logical volume(s) in volume group "Fedora" now active
Probing for video card:   nVidia Corporation GeForce 8600M GT
15:06:02 Starting graphical installation...

Thanks to Eddahbi Karim for submitting the problem.
Comment 1 Thomas Canniot 2008-04-06 06:00:22 EDT
In fact it fails with every non English languages. I could not start liveinst
with Deutsch language for example.
Comment 2 Jeremy Katz 2008-04-07 23:20:44 EDT
Fixed in git.  (Note: bugs in liveinst should be filed against anaconda)
Comment 3 Bug Zapper 2008-05-14 04:58:00 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Adam Jackson 2009-02-08 15:28:50 EST
Fixed since rhpxl 1.3.  Latest in F9 is rhpxl 1.9.

Note You need to log in before you can comment on or make changes to this bug.