Bug 441126 - pkcon failure in non-gui mode
pkcon failure in non-gui mode
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-06 11:02 EDT by Rahul Sundaram
Modified: 2013-03-13 01:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-18 05:04:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2008-04-06 11:02:55 EDT
Description of problem:

pkcon fails when run in a different VT or run level 3 showing that dbus is not
started which is a bogus error message since dbus is running just fine.
Comment 1 Richard Hughes 2008-04-07 05:35:27 EDT
Fixed in 18bff1599f9a22721d50b2e022044fce25a3cece, thanks.
Comment 2 Robin Norwood 2008-04-10 11:55:42 EDT
This isn't quite fixed yet - the error message is better, but we still need to
make it actually work from a VT.

Probably using this:

http://hal.freedesktop.org/docs/PolicyKit/polkit-polkit-simple.html#polkit-auth-obtain

instead of our current method of getting auth.
Comment 3 Bug Zapper 2008-05-14 04:58:29 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Joshua Jensen 2008-06-10 16:23:04 EDT
I'm noticing this as a bug too... I can't find a way to test run this and see it
actually succeeds.  Does this even work at all?  Does PackageKit-cron work
properly by not using a VT ?
Comment 5 Richard Hughes 2008-08-18 05:04:35 EDT
Yup, 0.2.4 is fixed and uses polkit-auth.

Note You need to log in before you can comment on or make changes to this bug.