Bug 441126 - pkcon failure in non-gui mode
Summary: pkcon failure in non-gui mode
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: PackageKit
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Nobody's working on this, feel free to take it
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-06 15:02 UTC by Rahul Sundaram
Modified: 2013-03-13 05:43 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-18 09:04:35 UTC


Attachments (Terms of Use)

Description Rahul Sundaram 2008-04-06 15:02:55 UTC
Description of problem:

pkcon fails when run in a different VT or run level 3 showing that dbus is not
started which is a bogus error message since dbus is running just fine.

Comment 1 Richard Hughes 2008-04-07 09:35:27 UTC
Fixed in 18bff1599f9a22721d50b2e022044fce25a3cece, thanks.

Comment 2 Robin Norwood 2008-04-10 15:55:42 UTC
This isn't quite fixed yet - the error message is better, but we still need to
make it actually work from a VT.

Probably using this:

http://hal.freedesktop.org/docs/PolicyKit/polkit-polkit-simple.html#polkit-auth-obtain

instead of our current method of getting auth.

Comment 3 Bug Zapper 2008-05-14 08:58:29 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 Joshua Jensen 2008-06-10 20:23:04 UTC
I'm noticing this as a bug too... I can't find a way to test run this and see it
actually succeeds.  Does this even work at all?  Does PackageKit-cron work
properly by not using a VT ?

Comment 5 Richard Hughes 2008-08-18 09:04:35 UTC
Yup, 0.2.4 is fixed and uses polkit-auth.


Note You need to log in before you can comment on or make changes to this bug.