Bug 441130 - SELinux is preventing the postfix from using potentially mislabeled files
SELinux is preventing the postfix from using potentially mislabeled files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-06 12:00 EDT by Anne
Modified: 2008-11-12 16:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-08 16:28:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SELinux output (1.82 KB, text/plain)
2008-04-06 12:00 EDT, Anne
no flags Details

  None (edit)
Description Anne 2008-04-06 12:00:55 EDT
Description of problem:
AVC is produced during setup of postfix.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Install postfix
2.Edit /etc/postfix/main.cfg and transport
3.Create hashes of aliases and transport

  
Actual results:

AVC produced

Expected results:

Postfix allowed to create databases

Additional info:
Comment 1 Anne 2008-04-06 12:00:55 EDT
Created attachment 301432 [details]
SELinux output
Comment 2 Daniel Walsh 2008-04-07 22:59:46 EDT
Not sure what is going on here. looks like postfix_master is trying to
read/write user files in /tmp?

Comment 3 Anne 2008-04-08 04:49:53 EDT
I will ask about that on the postfix list and report back
Comment 4 Anne 2008-04-08 15:49:36 EDT
After last night's update to selinux-policy-3.3.1-29 this problem appears to
have been resolved.  In my opinion this could now be marked as fixed.  I'm sorry
that we never found out why it happened, but at least it's OK now.

Note You need to log in before you can comment on or make changes to this bug.