Bug 441138 - Xen kernel on F9 Beta install DVD won't boot
Xen kernel on F9 Beta install DVD won't boot
Status: CLOSED DUPLICATE of bug 437930
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-06 13:53 EDT by D. Wagner
Modified: 2009-12-14 15:42 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-04 13:41:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description D. Wagner 2008-04-06 13:53:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.13) Gecko/20080325 Fedora/2.0.0.13-1.fc8 Firefox/2.0.0.13

Description of problem:
I installed from Fedora 9 Beta install DVD, and selected Xen in the graphical installer and selected the optional package(s) for Xen (maybe it was "xen" or "kernel-xen").  When I rebooted, boot failed.  I forgot to copy down the exact error message, but it failed very early in the boot, saying it could not find a file, which I assume was the kernel image.  The filename was something like "/xen-..." or "/boot/xen-...".  I apologize for how vague this bug report is; I forgot to copy down details.  If this isn't enough to reproduce, I apologize: feel free to ignore this bug report.

Smolt hardware profile:
http://www.smolts.org/client/show/?uuid=pub_41409e87-d32a-425f-a866-f1ec9064593a

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Steps to Reproduce:
1.
2.
3.

Actual Results:


Expected Results:


Additional info:
Comment 1 Rafal Wojtczuk 2008-05-04 13:18:26 EDT
The problem is that the installer created the grub.conf file with line
kernel /boot/xen.gz-2.6.25-0.24.rc9.fc9.i686.
instead of
kernel /boot/xen.gz-2.6.25-0.24.rc9.fc9.i686.xen
But fixing it is not enough. I tested on two i386 boxes, installation with the
F9 Preview DVD. On both, Xen boots fine, but dom0 fails to boot. The last log
line is "Xen is relinguishing vga console", and then apparently nothing happens.
I removed "rhgb quiet" from vmlinuz parameters, experimented with a few other
options (acpi=aff, initcall_debug, clocksource=acpi_pm), nothing changes -
vmlinuz does not boot.
If I use the F9 Preview xen.gz with an older kernel, e.g 
kernel /boot/xen.gz-2.6.25-0.24.rc9.fc9.i686.xen
module /boot/vmlinuz-2.6.21-7.fc7xen ro root=LABEL=/ rhgbkernel 
it boots OK. The combination 
xen.gz-2.6.21-7.fc7+vmlinuz-2.6.25-0.24.rc9.fc9.i686.xen
fails because of unsupported features required by dom0.
Anyway, it seems that the vmlinuz-2.6.25-0.24.rc9.fc9.i686.xen is at fault.
Comment 2 Daniel Berrange 2008-05-04 13:41:15 EDT
Xen Dom0 hosts are *NOT* supported in Fedora 9 as per this feature:

http://fedoraproject.org/wiki/Features/XenPvops


A feature is scheduled for F10 to attempt to re-introduce Dom0

http://fedoraproject.org/wiki/Features/XenPvopsDom0
Comment 3 Mark McLoughlin 2008-05-04 14:57:16 EDT

*** This bug has been marked as a duplicate of 437930 ***

Note You need to log in before you can comment on or make changes to this bug.