Bug 441152 - won't accept an interrupt or simple kill
won't accept an interrupt or simple kill
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dhcpv6 (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-06 17:06 EDT by Sam W.
Modified: 2008-04-06 20:09 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-06 20:09:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sam W. 2008-04-06 17:06:20 EDT
Description of problem:

run dhcp6c -D -f ethX
attempt to control-C out: it notices the signal, but won't exit
suspend it, attempt to kill, it doesn't exit.

Version-Release number of selected component (if applicable):

dhcpv6-client-0.10-51.fc8

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 David Cantrell 2008-04-06 20:09:24 EDT
This is fixed in at least dhcpv6-1.0.14 and higher, which are in rawhide.  F-8 has a very very old 
release of this software.

Some backstory...
I recently took over the dhcpv6 project.  It had been abandoned upstream and we (Red Hat and others) 
have been aggressively working on it since November of 2007 to comply with all RFCs and pass all TAHI 
tests.  F-8 has the last upstream release before I took over the project.  I have resurrected the project 
at:
http://fedorahosted.org/dhcpv6/

I'd love it if you could work with the latest upstream release and see how that's working in your 
environment.  I have been participating in IETF interoperability test session with this software to see 
how it works against other vendors' implementations.  So far the results have been more positive than I 
would have thought.  F-9 will have the latest upstream release of dhcpv6 in it.  If you'd like to see it in 
F-8 instead, let me know and I'll push out an update package for F-8.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.