Bug 441158 - Libvirt loses track of domains that have been created and the user tries to create again
Libvirt loses track of domains that have been created and the user tries to c...
Status: CLOSED WORKSFORME
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-06 17:48 EDT by Henri Cook
Modified: 2010-03-16 13:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-22 07:43:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Config file for domain in question (788 bytes, text/xml)
2008-04-06 17:48 EDT, Henri Cook
no flags Details

  None (edit)
Description Henri Cook 2008-04-06 17:48:58 EDT
Description of problem:

Occasionally 'virsh list' will say that a domain is not running when the process
is blatantly there in a ps faux - under libvirtd. This means the domain can't be
destroyed or created because of errors in both situations. Killing the process
results in a "[qemu-system-x86] <defunct>" process which can't be killed without
killing libvirtd and restarting it from init.d

Version-Release number of selected component (if applicable):

virsh -v == 0.4.0

How reproducible:

Very

Steps to Reproduce:
1. Create a domain
2. watch "virsh list" (in a seperate window)
3. Try to create the same domain again, the following error appears:
libvir: QEMU error : VM is already active
error: Failed to create domain from /home/virt/domains/Matilda/vm.cfg

Fair enough, but then the domain that was started previously disappears from
virsh list!
  
Actual results:

Please let me know if is reproduceible

Expected results:


Additional info:

Base System: 

Ubuntu Hardy latest over KVM
Comment 1 Henri Cook 2008-04-06 17:48:58 EDT
Created attachment 301440 [details]
Config file for domain in question
Comment 2 Daniel Veillard 2008-04-07 06:35:25 EDT
Changing Product, that's unrelated to Red Hat Enterprise or Fedora,
Please try with the latest upstream version i.e. libvirt-0.4.1 as 
many bugs were fixed since 0.4.0,

Daniel
Comment 3 Daniel Berrange 2009-01-22 07:43:07 EST
I've tried to reproduce this, but cannot. There should be no way for a defunct QEMU process not to be cleaned up by libvirt, because when we get a SIGHUP or EOF on the monitor socket we always call waitpid. If you can reproduce on latest upstream release (0.5.1) then please re-open.

Note You need to log in before you can comment on or make changes to this bug.