Bug 441199 - 855GME system freezes when switching to external monitor
Summary: 855GME system freezes when switching to external monitor
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drivers   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-07 05:12 UTC by Jeff D. Hanson
Modified: 2008-04-07 05:17 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 05:17:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeff D. Hanson 2008-04-07 05:12:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.13) Gecko/20080325 Ubuntu/7.10 (gutsy) Firefox/2.0.0.13

Description of problem:
Fedora 9 beta w/updates.  Panasonic CF-51 with 855GME integrated video.
If I use the Fn+F3 display switch without an external monitor connected the system usually freezes. No log messages, no magic SysReq, no remote ssh, no LED toggling, no messages on serial console - just a black screen with a frozen mouse cursor. It doesn't matter if the monitor was connected when X was started. Even with it connected the switch doesn't seem to have any effect on display switching as the view is cloned regardless. There is only a small display flicker when the switch is actuated to indicated that anything happened (unless it decides to freeze).  I tried switching to the i810 driver but it can't find any devices.  The vesa driver works and switches correctly with the external monitor connected and doesn't misbehave if it's not.

Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-2.2.1-19.fc9.i386

How reproducible:
Always


Steps to Reproduce:
1.Login to desktop with intel driver enabled.
2.Disconnect external monitor.
3.Attempt to switch to external monitor.

Actual Results:
Black screen with mouse cursor, system freeze.

Expected Results:
Either not switch or black out and return after subsequent key actuation.

Additional info:
A similar bug exists in Ubuntu Hardy 8.04 beta with a Toshiba M35X-S114 using the same chipset:  https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/213191

Comment 1 Jeff D. Hanson 2008-04-07 05:17:39 UTC
Accidental dupe of bug #441192


Note You need to log in before you can comment on or make changes to this bug.