Bug 441200 - rawhide guest install fails claiming tiny / partition
Summary: rawhide guest install fails claiming tiny / partition
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-07 05:13 UTC by Jens Petersen
Modified: 2008-07-16 07:52 UTC (History)
0 users

Fixed In Version: F9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-16 07:52:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jens Petersen 2008-04-07 05:13:21 UTC
Description of problem:
When I try to install rawhide under qemu I get an error dialog when
it tries to start the rpm transactions: it seems to think there is
on 55MB on / even though I allocated 5GB to the image under virt-manager.

How reproducible:
every time

Steps to Reproduce:
1. install rawhide under qemu
2. get to package installation
  
Actual results:
2. terse error dialog saying error occurred during transaction with details:
55 M on /


Expected results:
2. no error

Additional info:
This happens with both i386 and x86_64.

Comment 1 Jens Petersen 2008-04-07 05:22:44 UTC
Running df in a shell shows there is actually plenty of room on /.

Comment 2 Chris Lumens 2008-04-07 13:53:00 UTC
The complete error message should be:

Error Running Transaction
You need more space on the following file systems:
55 M on /

So, the error indicates that you need more space on the / filesystem, not that's
the size of the filesystem.  Are you not seeing this complete error message?

Comment 3 Jens Petersen 2008-04-11 05:45:42 UTC
No just the last line was appearing.

Fixed now in recent rawhide trees anyway.

Comment 4 Jens Petersen 2008-06-11 02:45:40 UTC
I am seeing this again trying to install current rawhide under kvm on f9.

Again the text box in the dialog just says:

45 M on /

(admittedly this is a Japanese install but that should not matter I think).

Rebooting might help...

Any other information I can provide?

Comment 5 Andy Lindeberg 2008-07-11 18:51:31 UTC
It actually was the Japanese that was a problem. The phrase to be translated was
not in unicode, but the widget was expecting a unicode string, so it complained
and displayed nothing. The same problem happened when I tried Russian, and when
I tried Turkish, French, and German, all of the accents (umlauts, circumflexes,
etc) got dropped.

There is a fix going into the next build of rawhide.

Comment 6 Jens Petersen 2008-07-14 02:26:30 UTC
Thanks

Um, and it is going to fix the "root" problem too?

Comment 7 Andy Lindeberg 2008-07-14 13:19:44 UTC
If by "root problem", you mean the error that caused the message, then no...
since that error message pops up when the user tries to install more packages
than can fit in the allotted space. The solution for that would be to either
give the partition more space, or select fewer packages.

Comment 8 Jens Petersen 2008-07-15 01:18:19 UTC
No, that is why there is the word "claiming" in the summary. :)

There is plenty of space but it is not seen by the installer that was the
problem: see comment 1.

Anyway it is no longer happening for me - so I guess it is ok.
Thanks for fixing the translations.

Comment 9 Andy Lindeberg 2008-07-15 15:36:39 UTC
Oh, I see. Can you give me the details of your partitioning and package
specifications? I'll try to reproduce it. (I was testing this with a 2 GB /
partition, not 5.)

Comment 10 Jens Petersen 2008-07-16 07:52:12 UTC
I was going to reopen and then remembered that I can't reproduce any more...

I'll close this for now and if I see it again come back.


Note You need to log in before you can comment on or make changes to this bug.