Bug 441205 - [gcin] gcin conflicts with SCIM when the latter is chosen as default.
[gcin] gcin conflicts with SCIM when the latter is chosen as default.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gcin (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Chung-Yen Chang
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-07 02:26 EDT by Caius Chance
Modified: 2008-07-02 02:35 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.4.2-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-02 02:35:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Caius Chance 2008-04-07 02:26:43 EDT
Description of problem:

gcin conflicts with SCIM when the latter is chosen as default:

XGetSelectionOwner: old version of gcin or gcin is not running ??
... try to start a new gcin server /usr/bin/gcin
gcin get env LC_CTYPE=(null)  LC_ALL=(null)  LANG=zh_TW.utf8
gcin XIM will use zh_TW.utf8 as the default encoding
merge tsin-1.src
Line 1 problem in phbufN!=chbufN 4 != 6
load_gtab_list /usr/share/gcin/table/gtab.list
gcin:IMOpenIM 'SCIM' failed. Maybe another XIM server is running.


Version-Release number of selected component (if applicable):
gcin-1.3.9-2.fc9.i386

How reproducible:
Always.

Steps to Reproduce:
1. login gnome.
2. use im-chooser to choose scim as default IME.
3. logout gnome then login.
4. start gnome-terminal and start stardict.
5. read the last part of console output.
  
Actual results:
gcin related error messages is outputted to console.

Expected results:
No gcin related error messages is outputted to console.

Additional info:
gcin even shouldn't be start when programs are started and gcin isn't a default IME.
Comment 1 Jens Petersen 2008-04-08 20:17:06 EDT
Doe this only happen with stardict?
Comment 2 Hu Zheng 2008-04-08 23:39:50 EDT
StarDict seems have some problem with xim protocol.

Maybe it is caused by this:
mainwin.cpp:99
gtk_container_forall(GTK_CONTAINER(WordCombo), unfocus_combo_arrow, this);
Comment 3 Bug Zapper 2008-05-14 05:00:40 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Fedora Update System 2008-06-27 04:36:55 EDT
gcin-1.4.2-2.fc9 has been submitted as an update for Fedora 9
Comment 5 Fedora Update System 2008-06-28 18:14:48 EDT
gcin-1.4.2-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gcin'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-5783
Comment 6 Fedora Update System 2008-07-02 02:35:23 EDT
gcin-1.4.2-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.