Bug 441215 - findks.cgi matching ip_address and mac_address is broken
findks.cgi matching ip_address and mac_address is broken
Status: CLOSED WONTFIX
Product: Fedora EPEL
Classification: Fedora
Component: cobbler (Show other bugs)
el5
All Linux
low Severity medium
: ---
: ---
Assigned To: Michael DeHaan
Fedora Extras Quality Assurance
ActualBug
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-07 03:52 EDT by Carsten Clasohm
Modified: 2009-06-24 14:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-24 14:57:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error message when accessing findks.cgi in a browser (10.16 KB, text/plain)
2008-04-07 03:52 EDT, Carsten Clasohm
no flags Details
patch which fixes IP and MAC address matches (1.37 KB, patch)
2008-04-07 03:53 EDT, Carsten Clasohm
no flags Details | Diff

  None (edit)
Description Carsten Clasohm 2008-04-07 03:52:34 EDT
Description of problem:

With the current version of Cobbler, the findks.cgi script does not work,
because the structure of the "system" record has changed. ip_address and
mac_address are no longer top-level keys.


Version-Release number of selected component (if applicable):

cobbler-0.8.2-1.el5

How reproducible:

always

Steps to Reproduce:

1. Create a system in the Cobbler Web UI, and set the MAC address or IP address
of the first interface.

2. Try to kickstart the system with the kickstart URL
http://server/cgi-bin/cobbler/findks.cgi
  
Actual results:

Kickstart does not work. If you access the findks.cgi script from your browser,
you see the error message attached as findks-error.txt.

Expected results:

Matching on IP or MAC address should work.

Additional info:

The attached findks.patch fixes this problem.
Comment 1 Carsten Clasohm 2008-04-07 03:52:34 EDT
Created attachment 301478 [details]
error message when accessing findks.cgi in a browser
Comment 2 Carsten Clasohm 2008-04-07 03:53:15 EDT
Created attachment 301479 [details]
patch which fixes IP and MAC address matches
Comment 3 Michael DeHaan 2009-06-24 14:57:41 EDT
Seeing recent changes to the CC list for this one, please note that cobbler no longer uses any more CGI scripts.

If we need to reinstate similar functionality, we should do it through the mod_python handler -- should be easy enough to do.

Open up an email to cobbler list if you are interested and I can offer some tips in terms of patching this... otherwise, will be pushed back a bit in the queue.

Note You need to log in before you can comment on or make changes to this bug.