Bug 441227 - firefox-1.5.0.12-14.el5_1 gives javascript error for salesforce.com
firefox-1.5.0.12-14.el5_1 gives javascript error for salesforce.com
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: firefox (Show other bugs)
5.1
All Linux
high Severity medium
: rc
: ---
Assigned To: Martin Stransky
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-07 05:41 EDT by Huzaifa S. Sidhpurwala
Modified: 2008-05-06 02:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 02:53:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Huzaifa S. Sidhpurwala 2008-04-07 05:41:33 EDT
Description of problem:
firefox-1.5.0.12-14.el5_1 gives java script error when trying to submit order in
salesforce.com 
The error is:

Error: uncaught exception: [Exception... "Component returned failure
code: 0x80004005 (NS_ERROR_FAILURE)
[nsIDOMHTMLSelectElement.selectedIndex]" nsresult: "0x80004005
(NS_ERROR_FAILURE)" location: "JS frame ::
http://www.trisweb.com/archives/2007/04/24/javascript-selectedindex-ns_error_failure/
:: onclick :: line 1" data: no]


Version-Release number of selected component (if applicable):
firefox-1.5.0.12-14.el5_1

firefox-3.0-0.beta4.1.el5.i386.rpm
and firefox2-2.0.0.13-1.rhis.i386.rpm

also fails

How reproducible:

You need a salesforce login to reproduce this.


Steps to Reproduce:
1. Login to salesforce
2. Submit an order
3. error
  
Actual results:
Java script error, does not work

Expected results:
Should allow to submit orders.

Additional info:
Comment 2 Mauricio Teixeira 2008-04-07 07:52:19 EDT
Note: 1.5.0.12-11 does not seem to crash.
Comment 3 Martin Stransky 2008-04-08 07:06:28 EDT
It's caused by mozilla-403168.patch in our packages (it's a fix for
https://bugzilla.mozilla.org/show_bug.cgi?id=403168)

Firefox 3 is affected, too.
Comment 4 Martin Stransky 2008-04-08 10:05:05 EDT
The exeption is raised by this line in connection.js script from salesforce.com:

this.connection.open("POST", this.url, async);

It fails in nsXMLHttpRequest::OpenRequest, at:

 rv = CheckInnerWindowCorrectness();

where fails the condition:

outer->GetCurrentInnerWindow() == win

----------------------------------------------------------------------------
#0  nsXMLHttpRequest::CheckInnerWindowCorrectness (this=0x35ec560) at
nsXMLHttpRequest.h:164
164             return NS_ERROR_FAILURE;
(gdb) l
159           nsCOMPtr<nsPIDOMWindow> win = do_QueryReferent(mOwner);
160           NS_ENSURE_STATE(win);
161           NS_ASSERTION(win->IsInnerWindow(), "Should have inner window
here!\n");
162           nsPIDOMWindow* outer = win->GetOuterWindow();
163           if (!outer || outer->GetCurrentInnerWindow() != win) {
164             return NS_ERROR_FAILURE;
165           }
166         }
167         return NS_OK;
168       }

Comment 7 Martin Stransky 2008-05-06 02:53:46 EDT
Closing as NOTABUG. Cross-windows XHR scripting has been disabled in latest
security update and is not supported in FF3.

Note You need to log in before you can comment on or make changes to this bug.