Bug 441256 - initscript does not report jserver status correctly
initscript does not report jserver status correctly
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: FreeWnn (Show other bugs)
4.7
All Linux
low Severity low
: ---
: ---
Assigned To: Jens Petersen
Bill Huang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-07 08:52 EDT by Petr Šplíchal
Modified: 2016-05-31 21:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-09 00:13:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Šplíchal 2008-04-07 08:52:05 EDT
Description of problem:
FreeWnn initscript doesn't report jserver status correctly.

Version-Release number of selected component (if applicable):
FreeWnn-1.10pl020-6.el4.x86_64

How reproducible:
Always

Steps to Reproduce:
# /etc/init.d/FreeWnn status
jserver (pid 17944) is running...
# echo $?
0

# /etc/init.d/FreeWnn stop
Shutting down FreeWnn:                                     [  OK  ]
# /etc/init.d/FreeWnn status
jserver is stopped
# echo $?
0

  
Actual results:
returns 0 in both cases

Expected results:
correct code according to guidelines:
http://intranet.corp.redhat.com/ic/intranet/InitscriptsSpec.html
http://intranet.corp.redhat.com/ic/intranet/InitscriptGuidelines.html
Comment 1 Jens Petersen 2009-02-09 00:13:08 EST
Deferring this since it looks unlikely ever to get fixed unless there is a need for a package update.

Note You need to log in before you can comment on or make changes to this bug.