Bug 441262 - yum-update + RPM both eat more then 1.2GB.
yum-update + RPM both eat more then 1.2GB.
Status: CLOSED DUPLICATE of bug 472507
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-07 09:34 EDT by Gilboa Davara
Modified: 2008-11-28 11:48 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-28 11:48:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum update log. (66.12 KB, text/plain)
2008-04-07 09:34 EDT, Gilboa Davara
no flags Details

  None (edit)
Description Gilboa Davara 2008-04-07 09:34:16 EDT
B9 updated to latest running on a VMWare virtual machine with 1GB RAM +
512MB swap.
Running yum update dies on 
Updating: glib2 ...
error: Couldn't fork %post: Cannot allocate memory.

Memory use:
$ free -m
               total      used       free     shared    buffers     cached
Mem:           989        980        9        0         4           167
-/+ buffers/cache:        807        181
Swap:          511        405        106

Once yum is killed (and caches are dropped)
$ echo 3 > /proc/sys/vm/drop_caches
$ free -m
               total      used       free     shared    buffers     cached
Mem:           989        235        754      0         0           22
-/+ buffers/cache:        211        777
Swap:          511        188        32

.. In short, yum update is eating >1.2GB of memory in-order to update
282 packages.

Yum log attached.

- Gilboa
Comment 1 Gilboa Davara 2008-04-07 09:34:17 EDT
Created attachment 301518 [details]
yum update log.
Comment 2 Bug Zapper 2008-05-14 05:02:08 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Panu Matilainen 2008-11-28 11:48:08 EST

*** This bug has been marked as a duplicate of bug 472507 ***

Note You need to log in before you can comment on or make changes to this bug.