Bug 44129 - "Segmentation fault" when using RPM
Summary: "Segmentation fault" when using RPM
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 6.1
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL: ftp://ftp.thorsen.se/pub/redhat/usr.l...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-11 19:35 UTC by Need Real Name
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-20 09:12:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-06-11 19:35:23 UTC
Description of Problem:

My intention was to upgrade my KDE environment to KDE 2.1

So I have Downloaded all RPM-files neccessary.

I followed the instructions & FAQs at www.kde.org/documentation/faq/install.html
(among the instructions I upgraded my RPM to version  4.0.2-6x using an RPM-file).

I started to install the qt-packages. Everything went well until I  installed the kdesupport-2* package.

I got a message that files in the new package was is conflikt with files in the old kdesupport-1* package. 

So I removed the old packge with the command rpm -e kdesupport-1..1.2*  . It got removed alright.

Then when trying to install the new package I got the message: "Segmentation fault (core dumped)"

I tried to re-install the old package again (with rpm -ivh ...) but I get the same errot message: "Segmentation fault ..."

So now I am without any kdesupportpackage and there seems to be way to get either one back.


I tried to rebuild the dependancy database with rpm --rebuilddb. But hte same message: "Segmentation fault ...." shows up.
I have also tried to re-create the file database with the command: updatedb. No success.

When I try to force an installation of either kdesupport package (by rpm ... --force) I get the meassage: "cannot open depends index using db1 - 
Invalid argument (22)"

How Reproducible:

Do not know

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
	
A tar-file of the directory cd /var/lib with subdirectories can be retrieved at the URL above.

My system is: Linux version 2.2.12-20 on an IBM ThinkPad 600. Redhat Linux with basic version 6.1 with some upgrades to 6.2 level (e.g.    
rpm version 4.0.2-6x).

Comment 1 Jeff Johnson 2001-06-14 14:30:41 UTC
Doing a --rebuildb with a recent version of rpm-4.0.3 (-0.37 is latest)
from Raw Hide will fix your problem. Please reopen this bug if you need more
help.

Comment 2 Need Real Name 2001-06-20 09:12:46 UTC
One probelm left.  I cannot find version -0.37 of RPM from RawHide. The latest version I have found is -0.31.

Where can i retreive version 4.0.3-0.37 of RPM  ??

/Ph

Comment 3 Jeff Johnson 2001-06-20 14:59:54 UTC
There should be a recent version of rpm-4.0.3 in Raw Hide, pushed yesterday
I;'ve been told. I'm still wortking on getting packages on ftp.rpm.org, soonish
...

Meanwhile, I can send you a repaired copy of your packages.rpm if
that would help. Send mail to <jbj@redhat.com> if so.


Note You need to log in before you can comment on or make changes to this bug.