Bug 441304 - ksshaskpass: make 'just work' via /etc/kde/env script (RFE)
ksshaskpass: make 'just work' via /etc/kde/env script (RFE)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ksshaskpass (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-07 10:30 EDT by Rex Dieter
Modified: 2008-04-07 10:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 10:32:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2008-04-07 10:30:12 EDT
Tried using ksshaskpass today, neat.  One idea I had would be to make this 'just
work' instead of the manual configuration as suggest in the current README.fedora.

One way to make this work would be to drop a file into
/etc/kde/env/ksshaskpass.sh
containing:
SSH_ASKPASS=/usr/bin/ksshaskpass
export SSH_ASKPASS

This is essentially what openssh-askpass does with
/etc/profile.d/gnome-ssh-askpass.sh
(I'd argue they shouldn't put that into profile.d, but that's their bug :) )
Comment 1 Rex Dieter 2008-04-07 10:32:25 EDT
nevermind, I was using F7, looks like you've already pretty much done this for
recent builds. thanks!

Note You need to log in before you can comment on or make changes to this bug.