Bug 441305 - only services for a vital system should have a default runlevel list in their initscript
only services for a vital system should have a default runlevel list in their...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: sagator (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jan ONDREJ
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-07 10:31 EDT by Karsten Hopp
Modified: 2008-08-07 01:15 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-07 01:15:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Openser init script update for packaging guidelines. (711 bytes, patch)
2008-04-07 13:45 EDT, Jan ONDREJ
no flags Details | Diff

  None (edit)
Description Karsten Hopp 2008-04-07 10:31:28 EDT
FPC and FESCo recently approved packaging guidelines for initscripts http://fedoraproject.org/wiki/Packaging/SysVInitScript . According to those guidelines only services which are really required for a vital system should define runlevels as the first parameter on the '# chkconfig: #' line in the initscript. Please consider changing the initscripts in this package.
Comment 1 Jan ONDREJ 2008-04-07 13:44:16 EDT
Because we are using upstream init script, I have done update in upstream.
Default init script runlevels have been removed.
Will be fixed in any later upstream release.

For those, who wants to see changes I am uploading svn diff.
Comment 2 Jan ONDREJ 2008-04-07 13:45:46 EDT
Created attachment 301543 [details]
Openser init script update for packaging guidelines.
Comment 3 Bug Zapper 2008-05-14 05:05:16 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Jan ONDREJ 2008-08-07 01:15:23 EDT
Fixed upstream and already in Fedora stable repository.

# chkconfig:    - 82 40

Closing this bug.

Previously attached patch is for wrong component, sorry.

Note You need to log in before you can comment on or make changes to this bug.