Bug 441314 - only services for a vital system should have a default runlevel list in their initscript
only services for a vital system should have a default runlevel list in their...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xguest (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-07 10:37 EDT by Karsten Hopp
Modified: 2008-04-09 08:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-09 08:07:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2008-04-07 10:37:15 EDT
FPC and FESCo recently approved packaging guidelines for initscripts http://fedoraproject.org/wiki/Packaging/SysVInitScript . According to those guidelines only services which are really required for a vital system should define runlevels as the first parameter on the '# chkconfig: #' line in the initscript. Please consider changing the initscripts in this package.
Comment 1 Daniel Walsh 2008-04-08 09:28:21 EDT
Ok I am not sure what vital means in this case.  If you do not run this init
script on boot, the xguest package will not work correctly.  This really is not
a service, it just sets up namespace correctly so that an xguest user can mount
usb keys while in a different namespace.  So if the reason for doing this change
is to speed up boot and not start apps that are not "vital" than this does not
really match that expectation.

So not sure what I am required to do?  Maybe this needs to be discussed on
fedora-devel list?
Comment 2 Karsten Hopp 2008-04-09 06:12:36 EDT
Right, the main reason for this change is startup time, the other is security.
If there isn't any daemon that gets started this can be closed as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.