Bug 441339 - Runlevel 1 -> 3 fails to kill bash
Runlevel 1 -> 3 fails to kill bash
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: upstart (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Casey Dahlin
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-07 13:03 EDT by Warren Togami
Modified: 2014-06-18 04:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-24 16:38:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2008-04-07 13:03:53 EDT
upstart-0.3.9-15.fc9.x86_64

1) Boot into runlevel 1 (Use single or 1 in your grub command line)
2) init 3
3) You see a login screen, but typing is screwed up because both the previous
shell and mingetty are running and fighting for stdin/stdout.
Comment 1 Scott James Remnant 2008-04-07 18:05:13 EDT
How is the sulogin shell run?
Comment 2 Warren Togami 2008-04-07 23:03:02 EDT
/etc/rc.d/rc1.d/S99single:
#!/bin/bash
#
#
# rc.single     This file is executed by init when it goes into runlevel
#               1, which is the administrative state. It kills all
#               deamons and then puts the system into single user mode.
#               Note that the file systems are kept mounted.
#
# Author:       Miquel van Smoorenburg, <miquels@drinkel.nl.mugnet.org>
#               Modified for RHS Linux by Damien Neil
#

. /etc/init.d/functions

if [ "$1" != "start" ]; then
   exit 0
fi

# this looks nicer
[ -x /usr/bin/clear ] && /usr/bin/clear

# Now go to the single user level.
echo $"Telling INIT to go to single user mode."
exec init -t1 S
Comment 4 Bug Zapper 2008-05-14 05:06:08 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Jon Stanley 2008-05-24 16:38:45 EDT
I can't reproduce this in released F9.  Just did this exact thing for another bug.

Note You need to log in before you can comment on or make changes to this bug.