Bug 441351 - naming is odd
naming is odd
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: tzdata (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Petr Machata
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-07 13:57 EDT by Bill Nottingham
Modified: 2015-05-04 21:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-08 09:02:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2008-04-07 13:57:38 EDT
Description of problem:

For the Dumont-d'Urville Antarctica station, the tzdata name is:

'Antarctica/DumontDUrville'

This seems to go against tzdata naming rules in a couple of ways:
- it leaves out the '-' (which exists in names such as America/Port-au-Prince)
- it randomly capitalizes a letter

Dumont-dUrville would at least seem better. Only noticed because it looks like a
typo the way it is now.

Version-Release number of selected component (if applicable):

tzdata-2008b-1.fc9
Comment 1 Petr Machata 2008-04-08 09:02:35 EDT
POSIX specifies that the length of a portable path component is at most 14
characters.  Port-au-Prince exactly fits this constraint, as does DumontDUrville.

Re the capitalization, this is likely result of the first point, there is just
no space to include delimiting characters.  DumontDUrville is then arguably
clearer than DumontdUrville, where the "d" seems to be part of the "Dumont". 
But in any case timezone identifiers are arbitrary, and their "sensible" naming
is just present for sake of sane maintenance; so I don't think it matters much.

Note You need to log in before you can comment on or make changes to this bug.