Bug 441356 - RHEL4: Need newer perl-HTML-Parser for spamassassin
RHEL4: Need newer perl-HTML-Parser for spamassassin
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: perl-HTML-Parser (Show other bugs)
4.7
All Linux
high Severity high
: rc
: ---
Assigned To: Stepan Kasal
desktop-bugs@redhat.com
:
Depends On:
Blocks: 311151
  Show dependency treegraph
 
Reported: 2008-04-07 14:20 EDT by Warren Togami
Modified: 2008-07-24 15:58 EDT (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2008-0729
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 15:58:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2008-04-07 14:20:04 EDT
Bug #311151 spamassassin upgrade for RHEL4 requires a newer version of
perl-HTML-Parser than what RHEL4 provides.  If we do not do this, then we cannot
upgrade spamassassin on RHEL4.

Upgrade RHEL4 to match RHEL5's
perl-HTML-Parser-3.55-1.fc6

We might name RHEL4's version:
perl-HTML-Parser-3.55-1.el4

Tim Burke says this needs both QA approval and for the perl owner to agree.
Comment 1 Stepan Kasal 2008-04-08 05:45:51 EDT
Reviewing file Changes, I noticed two sources of API incompatibility:
1) Since HTML-Parser-3.37 (2004-11-10), using HTML::Parser by creating a
subclass with modified method is no longer documented in the man page.  (It is
not clear if it still works or when it stopped working.)  But this interface was
used in HTML-Parser-2.x, which had its last release in 1999.
2) Since HTML-Parser-3.39_90 (2004-11-17), decoding Unicode entities is always
enabled.  This was a configure option previously and RHEL-4 had it disabled.
The upgrade from 3.35 to 3.55 presents four years of development: most
improvements happened in 2004, and only a few bug fixes in 2006 and 2007. I
conclude the new code has matured.

To sum up: I believe the function of this module is to parse current HTML, so
most of the customers will benefit from the many corrections introduced in the
development of the module.  The Unicode entities support also falls to the
category.  I believe these advantages overweight the slight risk of
incompatibility in the ancient corners of the API.

I recommend the upgrade of the module.
Comment 2 Warren Togami 2008-04-08 11:02:54 EDT
Assigned to you, does this mean you will be handling it?  I will need to wait
until it is built and in the buildroot before I am able to do Bug #311151.
Comment 13 errata-xmlrpc 2008-07-24 15:58:10 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0729.html

Note You need to log in before you can comment on or make changes to this bug.