Bug 441359 - Error when loading RRDs
Error when loading RRDs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rrdtool (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Jarod Wilson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-07 14:24 EDT by Terje Røsten
Modified: 2008-04-08 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-08 11:20:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Terje Røsten 2008-04-07 14:24:19 EDT
Description of problem:

$ perl -e 'use RRDs;'
RRDs object version 1.2999070803 does not match bootstrap parameter 1.29990708
at /usr/lib64/perl5/5.10.0/x86_64-linux-thread-multi/DynaLoader.pm line 226.
Compilation failed in require at -e line 1.
BEGIN failed--compilation aborted at -e line 1.

I tried to rebuild the rrdtool and rrdtool-perl, however that did not help

$ rpm -q perl
perl-5.10.0-20.fc9.x86_64

$ rpm -qa|grep rrd
rrdtool-perl-1.3-0.10.beta4.fc9.x86_64
rrdtool-1.3-0.10.beta4.fc9.x86_64


Any idea?
Comment 1 Jarod Wilson 2008-04-07 16:32:10 EDT
Nggggh. I'm guessing this might be somehow related to a change in perl 5.10.

$ grep -R 29990708 *
bindings/perl-shared/RRDs.pm:$VERSION=1.299907080300;
bindings/perl-piped/RRDp.pm:$VERSION=1.299907080300;

It seems the version string is getting truncated somewhere... But I really have
no clue who/what is at fault. Pinging some perl people...
Comment 2 Terje Røsten 2008-04-07 16:40:48 EDT
> Nggggh. I'm guessing this might be somehow related to a change in perl 5.10.
> 
> $ grep -R 29990708 *
> bindings/perl-shared/RRDs.pm:$VERSION=1.299907080300;
> bindings/perl-piped/RRDp.pm:$VERSION=1.299907080300;
> 
> It seems the version string is getting truncated somewhere... 

Yes, my initial belief too. Anyway, crazy long, makes me wonder
why such VERSION strings are needed!?

> But I really
> have  no clue who/what is at fault. Pinging some perl people...

Thanks :-)





 
Comment 3 Jarod Wilson 2008-04-07 17:31:03 EDT
Well, I think the version string will get bumped to 1.30 or something like that
once 1.3 is released, but since its still beta, we get the long
pre-1.3+date-based version. I have a short-term work-around I'll try in a sec,
since my perl contacts are ignoring me right now. :)
Comment 4 Jarod Wilson 2008-04-08 11:20:21 EDT
Successfully tested my local work-around, committing and building now.
Comment 5 Terje Røsten 2008-04-08 12:48:17 EDT
Works great here too, thanks for quick fix!

Note You need to log in before you can comment on or make changes to this bug.