Bug 441375 - beagle-thunderbird missing beagle.xpi
beagle-thunderbird missing beagle.xpi
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: beagle (Show other bugs)
9
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Adel Gadllah
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-07 15:20 EDT by Sachin Garg
Modified: 2008-07-27 13:42 EDT (History)
5 users (show)

See Also:
Fixed In Version: beagle-0.3.8-3.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-27 13:42:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sachin Garg 2008-04-07 15:20:26 EDT
Description of problem:

Beagle does not index the thunderbird email since the beagle.xpi is missing.

From the build in the koji. We are just compiling it but not installing it.

make[2]: Entering directory
`/builddir/build/BUILD/beagle-0.3.5/thunderbird-extension'
zip -q9 beagle.xpi chrome.manifest install.rdf chrome/beagle.jar
defaults/preferences/default.js components/BeagleIndexer.js
components/BeagleQueue.js components/BeagleSettings.js
components/BeagleCommandLine.js
make[2]: Leaving directory
`/builddir/build/BUILD/beagle-0.3.5/thunderbird-extension'


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:

No thunderbird mail getting index.

Expected results:

Beagle should index the thunderbird emails.

Additional info:
Comment 1 David Nielsen 2008-04-07 16:06:35 EDT
I will look into this, I have a sneaking idea that this requires the firefox
plugin which can't be used because it doesn't support the FF3 API.
Comment 2 Sachin Garg 2008-04-07 16:15:12 EDT
thunderbird+beagle works fine in Ubuntu(Hardy)
Comment 3 Konstantin Ryabitsev 2008-04-23 10:44:23 EDT
I don't think you need to worry about FF3 API -- thunderbird is staying at
version 2 for this release, I'm pretty sure.
Comment 4 Bug Zapper 2008-05-14 05:07:15 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Jonathan Kamens 2008-07-18 10:58:18 EDT
So, basically, email indexing and searching in thunderbird doesn't work at all,
and this is low priority?  How can that be?
Comment 6 Jonathan Kamens 2008-07-18 11:00:51 EDT
And why does the beagle-thunderbird RPM currently in Rawhide contain
/usr/lib/beagle/Backends/ThunderbirdBackends.dll and
/usr/lib/beagle/Backends/ThunderbirdBackends.dll.mdb, both of which are in the
beagle RPM as well, when I believe that what it *should* contain is the
thunderbird extension files?

Comment 7 Adel Gadllah 2008-07-19 10:19:07 EDT
Hi,
Thanks for the reminder somehow I completely missed this bug.

The good news are: I have fixed it. ;)

beagle-0.3.7-5.fc9 and beagle-0.3.8-2.fc10 should hit updates-testing / rawhide
soon. Please let me know if they work for you or not.
Comment 8 Fedora Update System 2008-07-19 10:28:04 EDT
beagle-0.3.7-5.fc9 has been submitted as an update for Fedora 9
Comment 9 Fedora Update System 2008-07-22 13:14:49 EDT
beagle-0.3.8-1.fc9 has been submitted as an update for Fedora 9
Comment 10 Fedora Update System 2008-07-23 22:13:01 EDT
beagle-0.3.8-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update beagle'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6690

Note You need to log in before you can comment on or make changes to this bug.