Bug 441380 - NIC Bonding Does Not Resolve on Startup
NIC Bonding Does Not Resolve on Startup
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-07 15:40 EDT by Steve Wells
Modified: 2014-03-16 23:13 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-14 16:38:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (42.26 KB, application/octet-stream)
2008-04-09 18:06 EDT, Steve Wells
no flags Details
Bonding Port Config (374 bytes, text/plain)
2008-04-14 14:53 EDT, Steve Wells
no flags Details
Bonding Port Config (363 bytes, text/plain)
2008-04-14 14:53 EDT, Steve Wells
no flags Details
Bonding Port Config (317 bytes, text/plain)
2008-04-14 14:54 EDT, Steve Wells
no flags Details

  None (edit)
Description Steve Wells 2008-04-07 15:40:52 EDT
Description of problem:

NIC Bonding is not resolving on system startup.  conventional setup with eth0
and eth1 as slaves & bond0 as master.  All are specified to start on boot. 
bootproto for bond0 is "dhcp" and eth0 and eth1 are "none".  When the system
starts up the connections are not established; ntp + sshd fails afterwards. 
Once the system is up, "service network restart" establishes the connections and
ntp + sshd restarts afterwards.

Version-Release number of selected component (if applicable):

Fedora Core 8

How reproducible:

regularly upon boot

Steps to Reproduce:
1. configure nic bonding
2. reboot system; note nic bonding fails
3. "service network restart" enables communications with nic bonding.
  
Actual results:

nic bonding fails on startup and requires follow-up restarting of network service

Expected results:

nic bonding to resolve on startup.

Additional info:
Comment 1 Dan Williams 2008-04-08 12:42:44 EDT
-> initscripts
Comment 2 Bill Nottingham 2008-04-08 13:14:24 EDT
What sort of messages do you get from the kernel?
Comment 3 Steve Wells 2008-04-09 18:06:24 EDT
Created attachment 301905 [details]
/var/log/messages

Attached is the messages file.

NOTE config specifies bootproto=none and generates warning (following) and same
config works fine upon service network restart.  One other note - when
restarting network service message is displayed, "shutting down interface
/etc/sysconfig/network-scripts/ifdown-eth1 line 105 :
/sys/classes/net/bond0/bonding/slaves : No Such File or Directory" (presumably
because the bond didn't set up first time).  Also note that while ifcfg-bond0
is set to onboot=yes, it doesn't appear in startup log.  Thanks.

Apr  9 13:09:38 ptapp1 NetworkManager: <WARN> 
nm_system_device_get_system_config(): Network configuration for device 'eth1'
was invalid (non-DHCP configuration, but no IP address specified.  Will use
DHCP instead.
Comment 4 Bill Nottingham 2008-04-09 22:50:56 EDT
Do you have NetworkManager enabled?
Comment 5 Steve Wells 2008-04-09 23:23:48 EDT
I have tried with network manager enabled and disabled.  Currently it is
disabled in the ifcfg-bond0 + ifcfg-eth0 + ifcfg-eth1 but I've tried with those
set to enabled, too.  I believe I may have also tried with varying combinations
ala enabled for bond but not for ports & vice-versa.  Do you have any specific
settings you'd like me to try?  Also, btw, I noticed in log that ntpd was
getting loaded before NetworkManager - should(n't) it be afterwards and what's
the optimal way to set that dependency?
Comment 6 Bill Nottingham 2008-04-09 23:30:51 EDT
What's the output of:

chkconfig --list NetworkManager
chkconfig --list network

Also, can you attach your ifcfg files?
Comment 7 Steve Wells 2008-04-14 14:53:42 EDT
Created attachment 302378 [details]
Bonding Port Config
Comment 8 Steve Wells 2008-04-14 14:53:57 EDT
Created attachment 302379 [details]
Bonding Port Config
Comment 9 Steve Wells 2008-04-14 14:54:06 EDT
Created attachment 302380 [details]
Bonding Port Config
Comment 10 Bill Nottingham 2008-04-14 15:24:11 EDT
And the chkconfig output?
Comment 11 Steve Wells 2008-04-14 16:25:51 EDT
After system startup, before network restart:

network        	0:off	1:off	2:off	3:off	4:off	5:off	6:off
NetworkManager 	0:off	1:off	2:on	3:on	4:on	5:on	6:off

After service network restart:

network        	0:off	1:off	2:off	3:off	4:off	5:off	6:off
NetworkManager  0:off   1:off   2:on    3:on    4:on    5:on    6:off

FYI - one time it seemed, upon system restart, a ping was issued ... whereby it
hung for considerable time (10 seconds) - but whereupon communications (some, at
least) were established without need for a service network restart.  However,
when thereafter issuing the service network restart, it (still) showed the stop
as failing and then succeeding on the startup.
Comment 12 Steve Wells 2008-04-14 16:30:02 EDT
This system is a Gateway 9425 server.  It has two stock 1 GB Intel ethernet
ports.  It also has an add-on Intel communications card.  In prior editions of
Fedora the onboard NICs were not recognized during startup (a known issue with
that chipset and earlier linux kernels) and thus required the addition of the
card.  FC8 recognizes the onboard NICs just fine (outside this reported issue) -
so the card is still there but we are using the onboard NICs and is how the
ifcfg-eth0 + ifcfg-eth1 files (previously attached) are configured.
Comment 13 Bill Nottingham 2008-04-14 16:38:51 EDT
You are running with NetworkManager enabled. That *will not work* with bonding.

You need to run:
- chkconfig --level 345 NetworkManager off
- chckonfig --level 345 network on
Comment 14 Steve Wells 2008-04-14 20:03:45 EDT
That does it!  THANKS!

One problem remaining is that SSHD is still failing upon first startup - what
setting or command will ensure proper dependency?
Comment 15 Bill Nottingham 2008-04-14 21:31:32 EDT
Shouldn't make a difference - what's the ssh error?
Comment 16 Steve Wells 2008-04-15 14:12:00 EDT
Corrected unrelated config issue to resolve - all OK on FC8 bootup :)

Thanks!

Note You need to log in before you can comment on or make changes to this bug.