Bug 441381 - RAWHIDE PackageKit dialogs do not appear when using KDE
RAWHIDE PackageKit dialogs do not appear when using KDE
Status: CLOSED DUPLICATE of bug 441062
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks: KDE4Live F9PKBlocker
  Show dependency treegraph
 
Reported: 2008-04-07 15:44 EDT by Shawn Starr
Modified: 2008-04-12 05:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-12 05:38:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shawn Starr 2008-04-07 15:44:59 EDT
Description of problem: PackageKit dialogs do not appear when using KDE. The 
gnome packagekit applet does appear but there's missing icons (another issue).

Version-Release number of selected component (if applicable):
All current versions of PK 0.10, 0.11 show this problem with KDE 4.0.3.

How reproducible:
Always reproducible, the dialogs pop up very briefly then vanish and do not 
display again.

Steps to Reproduce:
1. Start a KDE 4 session
2. Try to use any of the PackageKit gui tools ie, setup times to check for 
updates, dialog will not stay displayed.
3.
  
Actual results:

Any PackageKit dialog will not appear and the user cannot configure PK.

Expected results:

The user should be able to manage their system with PK from KDE.

Additional info:

WORKAROUND: use yum update from command line, not a good solution for users.
Comment 1 Richard Hughes 2008-04-08 17:15:12 EDT
Can you please run:

gpk-update-viewer --verbose

and attach the output to this bug. Thanks.
Comment 2 Shawn Starr 2008-04-10 21:13:17 EDT
$ gpk-update-viewer --verbose
TI:21:11:53     TH:0x90d6d68    FI:pk-debug.c   FN:pk_debug_init,248
 - Verbose debugging 1 (on console 1)
TI:21:11:53     TH:0x90d6d68    FI:pk-connection.c     
FN:pk_connection_connection_changed_cb,129
 - emit connection-changed: 1
TI:21:11:53     TH:0x90d6d68    FI:pk-client.c  FN:pk_client_connect,3342
 - connect
TI:21:11:53     TH:0x90d6d68    FI:pk-client.c  FN:pk_client_connect,3342
 - connect
TI:21:11:53     TH:0x90d6d68    FI:pk-job-list.c        FN:pk_job_list_connect,195
 - connect
TI:21:11:54     TH:0x90d6d68    FI:pk-client.c 
FN:pk_client_allocate_transaction_id,1261
 - Got tid: '2;cdacedae;data'
TI:21:11:54     TH:0x90d6d68    FI:pk-client.c  FN:pk_client_change_status,632
 - emit status-changed wait

(gpk-update-viewer:3289): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_width: assertion
`pixbuf != NULL' failed

(gpk-update-viewer:3289): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_height:
assertion `pixbuf != NULL' failed

(gpk-update-viewer:3289): GLib-GObject-CRITICAL **: g_object_unref: assertion
`G_IS_OBJECT (object)' failed
Segmentation fault


quick gdb bt:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb7fec720 (LWP 3319)]
0x0804c92f in g_cclosure_marshal_VOID__STRING ()
(gdb) bt
#0  0x0804c92f in g_cclosure_marshal_VOID__STRING ()
#1  0x0804cad5 in g_cclosure_marshal_VOID__STRING ()
#2  0x0804e28d in g_cclosure_marshal_VOID__STRING ()
#3  0x004265d6 in __libc_start_main () from /lib/libc.so.6
#4  0x0804bfd1 in g_cclosure_marshal_VOID__STRING ()
Comment 3 Shawn Starr 2008-04-10 21:16:33 EDT
I'm thinking somehow the images/pixmaps are not being shown causing this crash.
Since the about dialog which does appear has no packagekit logo icon even.
Comment 4 Richard Hughes 2008-04-11 11:23:17 EDT
Can you reproduce this if you use konsole in gnome? I really don't want to have
to install the whole kde desktop to try and reproduce :-)

Do you have gnome-icon-theme installed?
Comment 5 Shawn Starr 2008-04-11 22:23:04 EDT
gnome-icon-theme-2.22.0-5.fc9.noarch

yep.
Comment 6 Kevin Kofler 2008-04-12 01:41:42 EDT
Can you please try "thread apply all bt" in GDB instead of just "bt"? I think 
this is the backtrace for the wrong thread.
Comment 7 Richard Hughes 2008-04-12 05:38:10 EDT

*** This bug has been marked as a duplicate of 441062 ***

Note You need to log in before you can comment on or make changes to this bug.