This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 441399 - RFE: focus grab/release hotkey needs to be configurable
RFE: focus grab/release hotkey needs to be configurable
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gtk-vnc (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-07 16:42 EDT by Jason Farrell
Modified: 2008-08-10 16:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-10 16:26:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Farrell 2008-04-07 16:42:43 EDT
"Ctrl+Alt" appears to be a hardcoded default to grab/release focus from the host
OS, which makes many common key combos in the guest impossible (without the
"Send Ley" workaround menu.

I've used "Ctrl+Alt+Shift" in VMware for quite a while -- would be very nice if
virt-manager's hotkey combo was configurable as well. Ctrl-Alt-Backspace,
Ctrl-Alt-ArrowKey, etc.
Comment 1 Daniel Berrange 2008-04-07 16:59:49 EDT
The grab combo is defined by the GTK-VNC widget, so re-assigning the component.
Comment 2 Daniel Berrange 2008-04-07 17:02:11 EDT
A similar RFE has been made against Vinagre also using GTK-VNC
http://bugzilla.gnome.org/show_bug.cgi?id=501164
Comment 3 Jon Stanley 2008-04-23 16:29:13 EDT
Adding FutureFeature keyword to RFE's.
Comment 4 Paul W. Frields 2008-08-10 16:26:42 EDT
Triage here -- looks like this has been fixed upstream according to the bug report linked in the previous comment.  Closing.

Note You need to log in before you can comment on or make changes to this bug.