Bug 441401 - dhcp will not resolve correctly if /etc/dhclient.conf is missing
dhcp will not resolve correctly if /etc/dhclient.conf is missing
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-07 16:45 EDT by Alan Olsen
Modified: 2008-08-01 19:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-01 19:34:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alan Olsen 2008-04-07 16:45:09 EDT
Description of problem:
If /etc/dhclient.conf or /etc/dhclient-wlan0.conf is missing, my wireless
connection cannot get an ip address from dhcp.  If I use touch to create both of
those files, it works.


Version-Release number of selected component (if applicable): 4.0.0-14


How reproducible:
I have reproduced it multiple times on my x86_64 laptop with b43 chipset and 4.x
firmware.

Steps to Reproduce:
1. Try to connect with wireless and dhcp
2. touch /etc/dhclient.conf /etc/dhclient-wlan0.conf
3. Try to connect and it works
  
Actual results:
It needs those files to exist to get a dhcp addess on my wireless card.

Expected results:
It should not need those files.


Additional info:

I have no clue what causes this.  I have tried it multiple times with the same
results.  It is very weird.  eth0 connects fine with dhcp.
Comment 1 Bug Zapper 2008-05-14 05:07:21 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 David Cantrell 2008-08-01 19:34:12 EDT
I cannot reproduce this on the final F-9 release or on rawhide.  If you can provide more details about 
exactly how you are invoking dhclient and confirm that the bug is still happening in the F-9 final release, 
please reopen the bug and provide that information.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.