Bug 441414 - kernel: BUG: unable to handle kernel paging request at virtual address
kernel: BUG: unable to handle kernel paging request at virtual address
Status: CLOSED DUPLICATE of bug 432229
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-07 18:00 EDT by Will
Modified: 2008-04-08 15:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-08 15:57:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Will 2008-04-07 18:00:48 EDT
Description of problem:
System freezes or becomes "unresponsive".  A reboot is necessary to enable the
server again.  Here's the output from /var/log/messages:

Apr  7 12:32:04 mail kernel: BUG: unable to handle kernel paging request at
virtual address 950412de
Apr  7 12:32:04 mail kernel: printing eip: 08048823 *pde = 00000000
Apr  7 12:32:04 mail kernel: Oops: 0000 [#1] SMP
Apr  7 12:32:04 mail kernel: Modules linked in: hfsplus ipt_REJECT
iptable_filter iptable_mangle ipt_RED
IRECT iptable_nat nf_nat nf_conntrack_ipv4 ip_tables nf_conntrack_ipv6
ip6t_ipv6header ip6t_REJECT ip6ta
ble_filter ip6_tables xt_state nf_conntrack nfnetlink xt_tcpudp x_tables rfcomm
l2cap bluetooth autofs4
sunrpc ipv6 loop dm_multipath snd_intel8x0 snd_ac97_codec ac97_bus snd_seq_dummy
snd_seq_oss snd_seq_mid
i_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm parport_pc
parport snd_timer e100 mii s
nd floppy button i2c_i801 soundcore serio_raw i2c_core iTCO_wdt pcspkr
snd_page_alloc iTCO_vendor_suppor
t sg sr_mod cdrom dm_snapshot dm_zero dm_mirror dm_mod ata_generic ata_piix
libata sd_mod scsi_mod ext3
jbd mbcache uhci_hcd ohci_hcd ehci_hcd
Apr  7 12:32:04 mail kernel: CPU:    0
Apr  7 12:32:04 mail kernel: EIP:    0060:[<08048823>]    Not tainted VLI
Apr  7 12:32:04 mail kernel: EFLAGS: 00210293   (2.6.23.9-85.fc8 #1)
Apr  7 12:32:04 mail kernel: EIP is at 0x8048823
Apr  7 12:32:04 mail kernel: eax: 950412de   ebx: 00000004   ecx: 00200282  
edx: 00000000
Apr  7 12:32:04 mail kernel: esi: f6289f84   edi: ffffffe0   ebp: f6289e08  
esp: f6289df4
Apr  7 12:32:04 mail kernel: ds: 007b   es: 007b   fs: 00d8  gs: 0033  ss: 0068
Apr  7 12:32:04 mail kernel: Process wms (pid: 6001, ti=f6289000 task=c7057230
task.ti=f6289000)
Apr  7 12:32:04 mail kernel: Stack: 950412de 950412de 950412de 00000000 00000004
00000001 c046844e c049a
79c
Apr  7 12:32:04 mail kernel:        00000011 00000000 00000030 00000000 fffcffff
00000030 00000030 bf9f1
ab8
Apr  7 12:32:04 mail kernel:        c049af6b ffffffd0 00000000 00000000 f6289f2c
00000000 f6289fec cf5ba
480
Apr  7 12:32:04 mail kernel: Call Trace:
Apr  7 12:32:04 mail kernel:  [<c046844e>] put_compound_page+0x23/0x24
Apr  7 12:32:04 mail kernel:  [<c049a79c>] splice_to_pipe+0x1d7/0x1e7
Apr  7 12:32:04 mail kernel:  [<c049af6b>] sys_vmsplice+0x2d7/0x430
Apr  7 12:32:04 mail kernel:  [<c04ccc9a>] inode_has_perm+0x66/0x6e
Apr  7 12:32:04 mail kernel:  [<c0423ec2>] kunmap_atomic+0x60/0x96
Apr  7 12:32:04 mail kernel:  [<c046d6ba>] unmap_vmas+0x3d9/0x59a
Apr  7 12:32:04 mail kernel:  [<c04264a6>] __wake_up+0x32/0x43
Apr  7 12:32:04 mail kernel:  =======================
Apr  7 12:32:04 mail kernel: Code:  Bad EIP value.
Apr  7 12:32:04 mail kernel: EIP: [<08048823>] 0x8048823 SS:ESP 0068:f6289df4
Apr  7 12:32:06 mail kernel: BUG: unable to handle kernel paging request at
virtual address 22898909
Apr  7 12:32:06 mail kernel: printing eip: 08048823 *pde = 00000000
Apr  7 12:32:06 mail kernel: Oops: 0000 [#2] SMP
Apr  7 12:32:06 mail kernel: Modules linked in: hfsplus ipt_REJECT
iptable_filter iptable_mangle ipt_REDIRECT iptable_nat nf_nat nf_conntrack_ipv4
ip_tables nf_conntrack_ipv6 ip6t_ipv6header ip6t_REJECT ip6table_filter
ip6_tables xt_state nf_conntrack nfnetlink xt_tcpudp x_tables rfcomm l2cap
bluetooth autofs4sunrpc ipv6 loop dm_multipath snd_intel8x0 snd_ac97_codec
ac97_bus snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device
snd_pcm_oss snd_mixer_oss snd_pcm parport_pc parport snd_timer e100 mii snd
floppy button i2c_i801 soundcore serio_raw i2c_core iTCO_wdt pcspkr
snd_page_alloc iTCO_vendor_support sg sr_mod cdrom dm_snapshot dm_zero dm_mirror
dm_mod ata_generic ata_piix libata sd_mod scsi_mod ext3jbd mbcache uhci_hcd
ohci_hcd ehci_hcd
Apr  7 12:32:06 mail kernel: CPU:    0
Apr  7 12:32:06 mail kernel: EIP:    0060:[<08048823>]    Tainted: G      D VLI
Apr  7 12:32:06 mail kernel: EFLAGS: 00210293   (2.6.23.9-85.fc8 #1)
Apr  7 12:32:06 mail kernel: EIP is at 0x8048823
Apr  7 12:32:06 mail kernel: eax: 22898909   ebx: 00000004   ecx: 00200286  
edx: 00000000
Apr  7 12:32:06 mail kernel: esi: cb56bf84   edi: ffffffe0   ebp: cb56be08  
esp: cb56bdf4
Apr  7 12:32:06 mail kernel: ds: 007b   es: 007b   fs: 00d8  gs: 0033  ss: 0068
Apr  7 12:32:06 mail kernel: Process wms (pid: 6025, ti=cb56b000 task=c7057230
task.ti=cb56b000)
Apr  7 12:32:06 mail kernel: Stack: 22898909 22898909 22898909 00000000 00000004
00000001 c046844e c049a79c
Apr  7 12:32:06 mail kernel:        00000011 00000000 00000030 00000000 fffcffff
00000030 00000030 bfdce698
Apr  7 12:32:06 mail kernel:        c049af6b ffffffd0 00000000 00000000 cb56bf2c
00000000 cb56bfec f69740c0
Apr  7 12:32:06 mail kernel: Call Trace:
Apr  7 12:32:06 mail kernel:  [<c046844e>] put_compound_page+0x23/0x24
Apr  7 12:32:06 mail kernel:  [<c049a79c>] splice_to_pipe+0x1d7/0x1e7
Apr  7 12:32:06 mail kernel:  [<c049af6b>] sys_vmsplice+0x2d7/0x430
Apr  7 12:32:06 mail kernel:  [<c04ccc9a>] inode_has_perm+0x66/0x6e
Apr  7 12:32:06 mail kernel:  [<c0423ec2>] kunmap_atomic+0x60/0x96
Apr  7 12:32:06 mail kernel:  [<c046d6ba>] unmap_vmas+0x3d9/0x59a
Apr  7 12:32:06 mail kernel:  [<c04264a6>] __wake_up+0x32/0x43
Apr  7 12:32:06 mail kernel:  =======================
Apr  7 12:32:06 mail kernel: Code:  Bad EIP value.
Apr  7 12:32:06 mail kernel: EIP: [<08048823>] 0x8048823 SS:ESP 0068:cb56bdf4
Apr  7 12:32:10 mail kernel: audit(:0): major=252 name_count=0: freeing multiple
contexts (1)
Apr  7 12:32:10 mail kernel: audit(:0): major=316 name_count=0: freeing multiple
contexts (2)


Version-Release number of selected component (if applicable):


How reproducible:
Have not reproduced, happened first time, nor do I know how.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chuck Ebbert 2008-04-07 19:29:06 EDT
Umm, why are you reporting a bug against a kernel that is over four months old?
Comment 2 Jeffrey Moyer 2008-04-08 08:57:43 EDT
(In reply to comment #1)
> Umm, why are you reporting a bug against a kernel that is over four months old?

What's wrong with that, exactly?  If nothing else, it is good for archival
purposes.  If someone else hits the same bug on a current kernel, you'll know
that it's been around for a while.
Comment 3 Will 2008-04-08 14:35:09 EDT
I've updated to the latest kernel 2.6.24.4-64.fc8.  How would I know if this
specific bug was fixed in this new kernel?  

Should I close this bug then and to what status?
Comment 4 Chuck Ebbert 2008-04-08 15:57:35 EDT

*** This bug has been marked as a duplicate of 432229 ***

Note You need to log in before you can comment on or make changes to this bug.