Bug 441424 - partition map is sorted by anaconda during kickstart processing
Summary: partition map is sorted by anaconda during kickstart processing
Status: CLOSED DUPLICATE of bug 410011
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 4.6
Hardware: All
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-08 00:25 UTC by George R. Goffe
Modified: 2008-04-20 20:54 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-20 20:54:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description George R. Goffe 2008-04-08 00:25:58 UTC
Description of problem:

I enter my partitions the way I want them and in the order I want them but there
is a sort in anaconda that changes the order to alphabetical.

Version-Release number of selected component (if applicable):

All rhel versions and fedora core versions

How reproducible:

happens EVERY time

Steps to Reproduce:
1. make a ks.cfg file
2. put partitions in the order you want them to be
3. save the ks.cfg file WHICH shows the order you requested
4. do a kickstart with this config file
5. observe the partitions as they are laid out now (sorted)
  
Actual results:

Partitions sorted alphabetically

Expected results:

partitions laid out as specified in the ks.cfg file.

Additional info:

Comment 1 George R. Goffe 2008-04-08 00:26:55 UTC
Here's the partition layout as specified by my ks.cfg file:


#
### Partition our hard disks.
#
clearpart --all --initlabel 
part /boot --fstype ext3 --size=1024
part / --fstype ext3 --size=1024
part swap --fstype swap --size=12288
part /var --fstype ext3 --size=2048
part /opt --fstype ext3 --size=3072
part /usr --fstype ext3 --size=17408
part /export/home --fstype ext3 --size=4096 --grow 


Comment 2 Chris Lumens 2008-04-20 20:54:25 UTC

*** This bug has been marked as a duplicate of 410011 ***


Note You need to log in before you can comment on or make changes to this bug.