Bug 441444 - Using i915.modeset=1 causes an error message
Using i915.modeset=1 causes an error message
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-08 01:25 EDT by Bill Nottingham
Modified: 2014-03-16 23:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-26 12:30:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2008-04-08 01:25:05 EDT
Description of problem:

Using i915.modeset=1 to enable the modesetting kernel driver causes the kernel
to print out a message on boot about this being an unknown boot parameter.

It's pretty obvious now that 'quiet' mode is back on.

Version-Release number of selected component (if applicable):

kernel-2.6.25-0.204.rc8.git4.fc9.x86_64
Comment 1 Chuck Ebbert 2008-04-11 12:49:11 EDT
It's not built in so you need to put that in modprobe.conf.

If this is happening on the live CD or install disk the parameter is working
because the code that loads the driver parses the kernel command line to pick
this up. There doesn't seem to be any good way of killing that warning though.
Comment 2 Bill Nottingham 2008-04-11 13:38:13 EDT
See /etc/modprobe.d/i915modeset - it's set up to be configued via /proc/cmdline
Comment 3 Chuck Ebbert 2008-04-11 18:27:48 EDT
So the kernel warning is bogus but there's no good way to kill it. Turning off
the warnings completely would make it hard to find real mistakes in the command
line.
Comment 4 Chuck Ebbert 2008-04-26 12:30:12 EDT
Upstream has been debating this problem but nobody has a good answer yet.

Note You need to log in before you can comment on or make changes to this bug.