Bug 441454 - cpufreq stress test cause ondemand governor deadlock
cpufreq stress test cause ondemand governor deadlock
Status: CLOSED DUPLICATE of bug 449004
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: John Villalovos
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-08 03:49 EDT by Song, Youquan
Modified: 2015-05-08 09:57 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-13 15:42:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cpufreq_stress test case and and sysrq+t log and ps -aux log. (48.35 KB, application/octet-stream)
2008-04-08 03:49 EDT, Song, Youquan
no flags Details

  None (edit)
Description Song, Youquan 2008-04-08 03:49:31 EDT
Description of problem:

cpufreq stress test will cause ondemand governor deadlock on Harwich-
Truland,4x Xeon 7130 3.2GHz;E8501;DP 2x1M L2 8M L3 800MHz, RHEL5.2 snapshot1.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. get the cpufreq_stress test case in the attachment 
2 [details]. cd cpufreq_stress/initial; make
3. ./cpufreq_stress

  
Actual results:
After 7~8 hours, ps -aux find that kondemand daemon deadlock. 
cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor will hung.

Expected results:


Additional info:
Comment 1 Song, Youquan 2008-04-08 03:49:31 EDT
Created attachment 301612 [details]
cpufreq_stress test case and and sysrq+t log and ps -aux log.
Comment 2 Jarod Wilson 2008-04-08 11:10:23 EDT
This is actually a kernel problem, not a cpuspeed package problem, reassigning
to the correct component.
Comment 3 Peter Martuccelli 2008-07-25 12:20:54 EDT
John please work with Matthew and determine if this is still a problem after the
RHEL 5.3 updates to power management are in the kernel.  Please work on
reproducing the problem in the Westford lab.
Comment 4 Matthew Garrett 2008-07-25 13:14:09 EDT
At a guess, it's CPU hotplug related - the locking for that was broken for a
long time. I'll look into the current code and see if there's an obvious fix.
Comment 5 John Villalovos 2008-07-28 09:59:53 EDT
Is this related to Bug 449004
Comment 6 Prarit Bhargava 2008-07-28 10:08:03 EDT
(In reply to comment #5)
> Is this related to Bug 449004

I don't think so.  AFAICT, someone did a alt-sysrq-t (and that caused the soft
lockup warnings at the end of the sysrq dump).  It looks significantly different
from the 449004 (where we see a series of softlockup messages).

P.
Comment 7 John Villalovos 2008-07-28 10:16:01 EDT
Youquan,

Let us know if they are related.  I wasn't sure if you created this Bugzilla,
then created the Issue Tracker, which then spawned Bug 449004

John
Comment 8 Song, Youquan 2008-07-28 21:59:06 EDT
Yes. this bug is relate to Bug 449004. Bug 449004 has the modified test case 
with which we can easier to reproduce the bug. so this bug is duplicate with 
Bug 449004. 
Comment 9 John Villalovos 2009-08-13 15:42:27 EDT

*** This bug has been marked as a duplicate of bug 449004 ***

Note You need to log in before you can comment on or make changes to this bug.