This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 441457 - Plugging in usb wireless adapter immediately hangs system
Plugging in usb wireless adapter immediately hangs system
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-08 04:04 EDT by Mike C
Modified: 2008-04-16 08:24 EDT (History)
1 user (show)

See Also:
Fixed In Version: kernel-2.6.25-0.234.rc9.git1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-16 08:24:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen showing output immediately after plugging in usb adapter (396.70 KB, image/jpeg)
2008-04-09 04:09 EDT, Mike C
no flags Details
Screen about 20 seconds after image in previous attachment (395.48 KB, image/jpeg)
2008-04-09 04:10 EDT, Mike C
no flags Details
printk captured via netconsole (equivalent to images above) (1.84 KB, text/plain)
2008-04-09 17:36 EDT, Mike C
no flags Details

  None (edit)
Description Mike C 2008-04-08 04:04:09 EDT
Description of problem:Plugging in Edimax EW-7318UG (version V3.0B) usb wireless
adapter immediately hangs the system. Alt-SysRq-b is needed to reboot.


Version-Release number of selected component (if
applicable):kernel-2.6.25-0.200.rc8.git3.fc9.i686 (also .201 and .204)


How reproducible:Every time


Steps to Reproduce: 
1. Boot machine without wireless adapter plugged in
2. Plug in wireless adapter
3.
  
Actual results: System immediately hangs, and there is no response from
mouse/keyboard or ctrl-alt-backspace (desktop is kde and login manager is kdm)
Alt-Sysrq-b will reboot the machine.


Expected results: System should continue working with the rt73usb module loaded
correctly so that wireless communication can then be established using
wpa_supplicant.


Additional info: Kernels from .185 and earlier worked fine with this adapter.
wpa_supplicant works fine with kernels up to .185 but will not work with .200
through .204 since as soon as the wireless adapter is plugged in the system
crashes.

With kernel .204 the only entry in /var/log/messages was:
Apr  7 21:55:37 rawhide kernel: usb 1-1: new full speed USB device using
uhci_hcd and address 2

The hardware is
http://www.smolts.org/client/show/pub_c02c95fc-b8de-4916-85fe-cf1c96f33f7e
Comment 1 Pete Zaitcev 2008-04-08 13:40:21 EDT
It's likely the rsyslogd is unable to write the crash into files.

What does happen if you're on text console when you plug it in?
Please do this:
 <Ctrl><Alt>F1
 log in as root
 echo 8 > /proc/sys/kernel/printk
 resizecons -lines 50
 plug the adapter in
At this point you are likely to see a traceback which can be taken
with a camera (capturing it with netconsole would be even better,
but that requires reading Documentation/networking/netconsole.txt
which is confusing and out of date, then installing netcat (which
RPM is named "nc" in Fedora)).
Comment 2 Mike C 2008-04-09 04:09:06 EDT
Created attachment 301760 [details]
Screen showing output immediately after plugging in usb adapter

Following #1 this is the screen a few seconds after logging in to KDE, then
switching to an alternative console and logging in as root, and setting up to
print diagnostics. After 20 seconds more text appears on the screen and the
next image shows the further lines output.
Comment 3 Mike C 2008-04-09 04:10:22 EDT
Created attachment 301761 [details]
Screen about 20 seconds after image in previous attachment

About 20 seconds later there are further lines.
Comment 4 Mike C 2008-04-09 17:36:18 EDT
Created attachment 301900 [details]
printk captured via netconsole (equivalent to images above)

I managed to get a capture on a second machine on the same network using
netconsole. Here is the capture.
Comment 5 John W. Linville 2008-04-15 16:37:39 EDT
A patch to correct this should be available in 
kernel-2.6.25-0.234.rc9.git1.fc9 or later...probably available tomorrow or the 
next day...FYI! :-)
Comment 7 Mike C 2008-04-16 05:40:56 EDT
Thanks John - will test this later today or tomorrow.... and report back.
Comment 8 Mike C 2008-04-16 06:37:22 EDT
kernel-2.6.25-0.234.rc9.git1.fc9 resolves this bug and wireless now works nicely
again. This bug can now be closed. Thanks for working on this.

Note You need to log in before you can comment on or make changes to this bug.