Bug 441460 - useradd error message unhelpful
useradd error message unhelpful
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: shadow-utils (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Vrabec
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-08 04:28 EDT by JW
Modified: 2008-04-09 01:21 EDT (History)
1 user (show)

See Also:
Fixed In Version: 4.0.18.1-22.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-09 01:21:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description JW 2008-04-08 04:28:44 EDT
Description of problem:
useradd doesn't like telling you why the command-line is a syntax error
And/or the particular command-line is not faulty.

Version-Release number of selected component (if applicable):
shadow-utils-4.0.18.1-18

How reproducible:
Always

Steps to Reproduce:
1. useradd -M -b /home/users testac


Actual results:
Usage: useradd [options] LOGIN
Options:....


Expected results:
Should work, or should say why it is a syntax error.

Additional info:
There is nothing in the usage or manual to indicate that -M or -b are somehow
exclusive.  There is nothing wrong with specifying -M (dont create home
directory) and the -b option (where home directory base is ... needed to enter
into passwd file anyhow).

Apparently -b requires a -D. But the plain usage() is really quite lame and
unhelpful. Wouldn't all those usage()'s be better replaced with fatal("This is
the reason for the failure").

How much would that cost?
Comment 1 Fedora Update System 2008-04-08 09:20:50 EDT
shadow-utils-4.0.18.1-22.fc8 has been submitted as an update for Fedora 8
Comment 2 JW 2008-04-08 09:47:41 EDT
shadow-utils-4.1.1 looks a lot better with useful error messages.
Comment 3 Fedora Update System 2008-04-09 01:21:51 EDT
shadow-utils-4.0.18.1-22.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.