Bug 441467 - pup backtraced while getting package info
Summary: pup backtraced while getting package info
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pirut (Show other bugs)
(Show other bugs)
Version: 5.2
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: James Antill
QA Contact:
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-08 09:38 UTC by Michal Nowak
Modified: 2013-03-08 02:04 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-17 13:54:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace from crashed pup (18.11 KB, text/plain)
2008-04-08 09:38 UTC, Michal Nowak
no flags Details
And now, after some time, again (19.08 KB, text/plain)
2008-04-16 10:46 UTC, Michal Nowak
no flags Details

Description Michal Nowak 2008-04-08 09:38:14 UTC
Description of problem:

While connected via ssh -Y to remote server I got attached backtrace. The
problem is not happening anymore, I guess RHN was the problem but I guess pup
should not crash when got improper data. More details might be seen in attached
log -- if there's nothing just close...

(Just my assumption.)

Version-Release number of selected component (if applicable):
pirut-1.3.28-13.el5.noarch

How reproducible:
always (that time)

Steps to Reproduce:
1. pup
2. <asplode...>

Actual results:
crash

Expected results:
do not crash when received wrong data

Comment 1 Michal Nowak 2008-04-08 09:38:14 UTC
Created attachment 301615 [details]
backtrace from crashed pup

Comment 2 Michal Nowak 2008-04-16 10:46:18 UTC
Created attachment 302578 [details]
And now, after some time, again

Comment 3 James Antill 2008-04-16 14:06:03 UTC
 Ok, yeh ... all the XML processing in yum and related tools is strict and
always has been, you need to fix whatever is generating this (I assume RHN?) ...
we really need xmllint to be run on the output before it goes live.


Comment 4 Michal Nowak 2008-04-17 07:49:09 UTC
I'd expect pup not to completely blow up with bt but issue error msg "Hey, the
the data I'm receiving from satellite/hosted are messed up. Bug your admin."

Yum did not asplode in this situation.

Comment 5 James Antill 2008-04-17 13:54:30 UTC
 yum doesn't blow up because it doesn't load the updateinfo.xml file by default,
if you use the --security it will blow up in the same way.
 Yes, in theory, we could catch all the exceptions that libxml raises and print
a message like "your FOO xml file is broken", but we don't ... and it's not
supposed to be a "common" error.

 Feel free to open an RFE against yum Fedora and we'll look at it.


Note You need to log in before you can comment on or make changes to this bug.