Bug 441469 - File conflict in dapl 32/64bit packages
File conflict in dapl 32/64bit packages
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: releng (Show other bugs)
5.2
ia64 Linux
low Severity low
: rc
: ---
Assigned To: Dennis Gregorovic
Alexander Todorov
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-08 06:01 EDT by Alexander Todorov
Modified: 2008-05-21 11:41 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHEA-2008-0436
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:41:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2008-04-08 06:01:49 EDT
Description of problem:
File conflict when trying to install dapl-static and compat-dapl-static 32bit
packages on a system where the 64bit ones are installed already.

Version-Release number of selected component (if applicable):
TREE: RHEL5.2-Server-snap#4

compat-dapl-static-1.2.5-2.0.7-1.el5.ia64.rpm
compat-dapl-static-1.2.5-2.0.7-1.el5.i386.rpm

dapl-static-2.0.7-1.el5.ia64.rpm
dapl-static-2.0.7-1.el5.i386.rpm



How reproducible:
100%

Steps to Reproduce:
1. Install the dapl-static/compat-dapl-static packages (@everything)
2. Install the ia32el from supplementary disk
3. Install 32bit versions of dapl-static/compat-dapl-static
  
Actual results:
File conflicts, packages can not be installed.

Expected results:
No file conflicts. Packages are installed.

Additional info:
compat-dapl-static-1.2 and dapl-static-2.0 are 2 major versions of the same
software component which should be able to co-exist on the same system.

file listings:

[atodorov@hank ia64]$ rpm -qpl os/Server/dapl-static-2.0.7-1.el5.ia64.rpm 
/usr/lib/libdaplofa.a
/usr/lib/libdat2.a
[atodorov@hank ia64]$ rpm -qpl compatlayer/Server/dapl-static-2.0.7-1.el5.i386.rpm 
/usr/lib/libdaplofa.a
/usr/lib/libdat2.a
[atodorov@hank ia64]$ rpm -qpl
os/Server/compat-dapl-static-1.2.5-2.0.7-1.el5.ia64.rpm 
/usr/lib/libdaplcma.a
/usr/lib/libdat.a
[atodorov@hank ia64]$ rpm -qpl
compatlayer/Server/compat-dapl-static-1.2.5-2.0.7-1.el5.i386.rpm 
/usr/lib/libdaplcma.a
/usr/lib/libdat.a
Comment 7 Dennis Gregorovic 2008-04-09 12:58:47 EDT
Fix checked into distill.
Comment 11 errata-xmlrpc 2008-05-21 11:41:20 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2008-0436.html

Note You need to log in before you can comment on or make changes to this bug.