Bug 441484 - yum erases running kernel
yum erases running kernel
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-08 08:36 EDT by Thomas Woerner
Modified: 2014-01-21 18:02 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-14 20:03:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
var/log/messages filtered to include kernel, yum and errors (3.96 KB, text/plain)
2008-04-12 00:01 EDT, David Timms
no flags Details

  None (edit)
Description Thomas Woerner 2008-04-08 08:36:06 EDT
Description of problem:
If you have an older kernel running (more than two newer kernels available) 
yum erases the running kernel. This leads to big problems if you have to load a
not already loaded kernel module or if you restart the firewall.

Version-Release number of selected component (if applicable):
yum-3.2.13-2.fc9
Comment 1 Jeremy Katz 2008-04-08 10:03:07 EDT
I wonder if we're getting caught up by the change in kernel binary naming. 
Although it looks like it's okay from a quick look
Comment 2 David Timms 2008-04-11 23:55:13 EDT
I guess I'm not just lucky then; f8>f9beta>updated:
$ rpm -qa kernel\*|sort
kernel-2.6.25-0.201.rc8.git4.fc9.i686
kernel-2.6.25-0.204.rc8.git4.fc9.i686
kernel-2.6.25-0.218.rc8.git7.fc9.i686
kernel-devel-2.6.25-0.218.rc8.git7.fc9.i686
kernel-headers-2.6.25-0.218.rc8.git7.fc9.i386
kerneloops-0.10-11.fc9.i386
$ uname -a
Linux poweredge 2.6.25-0.195.rc8.git1.fc9.i686 #1 SMP Thu Apr 3 09:42:34 EDT
2008 i686 i686 i386 GNU/Linux
Comment 3 David Timms 2008-04-12 00:01:45 EDT
Created attachment 302192 [details]
var/log/messages filtered to include kernel, yum and errors

Notice that as well as nuking the running kernel: Apr 12 00:05:01,
there is getting two messages into the log stating the same kernel has been
installed.

It seems the second one of these should actually be the Removed: kernel-x.y.z
message {although I know version-release isn't normally logged for removals -
it would be better if it did.}
Comment 4 Jeremy Katz 2008-04-14 20:03:15 EDT
Reproduced and pushed the fix upstream

Note You need to log in before you can comment on or make changes to this bug.