Bug 441493 - codeina dep chain made livecd grow by 20 megs
codeina dep chain made livecd grow by 20 megs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: codeina (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9PR
  Show dependency treegraph
 
Reported: 2008-04-08 09:35 EDT by Jeremy Katz
Modified: 2008-04-08 17:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-08 17:28:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2008-04-08 09:35:44 EDT
The new version of codeina has an incredibly long new set of deps which has
taken livecds from having a comfortable safety cushion to being 20 megs over
(post-compression).  

Notable things that look a little odd:
* Dep on redhat-lsb.  This is incredibly expensive as it ends up bringing in a
lot of things like binutils, m4, etc which aren't at all needed in the general
case.  What's needed out of redhat-lsb?
* twisted.  This one is probably a little less easy to unravel, but twisted
brings along PyXML, SOAP, pyOpenSSL and about 15-20 megs (uncompressed) of
stuff.  Of which I suspect codeina is at most using a tiny subset :-/
Comment 1 Jeremy Katz 2008-04-08 10:00:38 EDT
Being assigned to orphan owner doesn't really help much.
Comment 2 Jeremy Katz 2008-04-08 10:09:16 EDT
And actually, it looks like all of this is due to bumping to current upstream
with all of the "get from third party places" features.  Feature freeze was
weeks ago and so we probably should just ship the f8+updates state for F9 and
then get the new stuff in order for F10 (and potentially an f9 update)
Comment 3 Bastien Nocera 2008-04-08 10:12:27 EDT
I was hoping we could make do with the new upstream version for this beta
release. It's very likely we'll switch back to the old version before gold though.
Comment 4 Jeremy Katz 2008-04-08 10:24:42 EDT
That kind of defeats the purpose of the preview release.  The purpose is so that
we get testing of the bits _we're going to ship_ so that we can find any
problems that need to be fixed and ensure high quality of the final release.

And given the added hit of "it breaks the livecd" (from a space perspective),
that makes doing some new and then fallback later dance even less attractive.
Comment 5 Bastien Nocera 2008-04-08 10:57:27 EDT
Given the amount of time I was given by the board to get it added and updated,
it's the best I could do.
Comment 6 Jeremy Katz 2008-04-08 13:53:36 EDT
The intention from the board discussion was, for Fedora 9, to just go back to
the status quo of what was shipped in F8+updates.  See the most recent board minutes
Comment 7 Paul W. Frields 2008-04-08 15:52:47 EDT
Couldn't it simply have had the release number bumped, then been tagged and
built from the source already in the CVS lookaside?  Now that requires an epoch
bump too.
Comment 8 Bastien Nocera 2008-04-08 17:28:59 EDT
codeina-0.10.1-8.fc9 is tagged for f9-final.

Note You need to log in before you can comment on or make changes to this bug.