Bug 441495 - No reason for bind binaries to be protected
No reason for bind binaries to be protected
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: bind (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: Adam Tkac
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-08 09:47 EDT by Chris Adams
Modified: 2013-04-30 19:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 17:16:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Adams 2008-04-08 09:47:17 EDT
I set up a new RHEL 5 nameserver today, and the named user is unable to use rndc
(despite having permission to read the rndc.conf/rndc.key files).  I realized
that the rndc binary (and all of the other binaries from the bind RPM) are only
readable by root.

There is no reason for this protection, as none of the binaries are
setuid/setgid or contain private information (especially since anyone could
build their own copy of bind, even from the RHEL SRPM, to get the same rndc
functionality).  This permission setting just means that access cannot be
delegated, which is actually less secure (as now more system operation can only
be done as root).

This is also an issue with the Fedora bind RPM, although there some (but not
all) binaries have been changed to world-readable/executable (see BZ 200465 and
BZ 427826 for example).
Comment 1 Adam Tkac 2008-04-25 07:50:07 EDT
You're right, current permissions are not really good. I'm going to revise them
in next bind update.
Comment 2 Chris Adams 2008-04-25 08:52:07 EDT
Thanks.
Comment 3 RHEL Product and Program Management 2008-07-21 19:03:49 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 9 errata-xmlrpc 2009-01-20 17:16:34 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0246.html

Note You need to log in before you can comment on or make changes to this bug.