Bug 441506 - pulseaudio doesn't remember default output device
pulseaudio doesn't remember default output device
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pavucontrol (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-08 10:52 EDT by Charles R. Anderson
Modified: 2009-02-24 20:29 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-24 20:29:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles R. Anderson 2008-04-08 10:52:18 EDT
Description of problem:

I have two sound cards, a built-in Intel ICH7 and a PCI Soundblaster Live!. 
Both devices show up in the PulseAudio Volume Control, and by default the ICH7
one is selected for output.  I don't have speakers attached to the ICH7 one, so
I have changed the default output device to the Soundblaster (ADC
Capture/Standard PCM Playback).  This setting doesn't survive logout/login.

Version-Release number of selected component (if applicable):
pulseaudio-0.9.10-1.fc9.i386
pavucontrol-0.9.5-2.fc9.i386

How reproducible:
always

Steps to Reproduce:
1. pavucontrol
2. in Output Devices tab, right click and select Default output device
3. play sounds, notice this works
4. logout, login, notice that default is no longer checked.
Comment 1 Lennart Poettering 2008-05-02 10:43:29 EDT
Normally PA should remember this. Maybe you are killing PA on session logout
without letting it store its settings first? Is this GNOME? Is module-x11-xsmp
poperly loaded?
Comment 2 Charles R. Anderson 2008-05-02 13:10:31 EDT
pulseaudio-0.9.10-1.fc9.i386
pavucontrol-0.9.6-1.fc9.i386

It doesn't look like I have module-x11-xsmp loaded:

>pactl list | grep x11
Name: module-x11-publish

I'm not killing anything manually before logging out...

Once I've moved an application's streams over by right-clicking the stream and
assigning a new output device, that setting is remembered across logout/login or
reboot.  However, new applications that have never before played still default
to the wrong device.

Also, pavucontrol still has "Default" checked for "ALSA PCM on front:1 (Intel
ICH7) via DMA" on the "Output Devices" tab when I right click it.  If I
right-click "ALSA PCM on front:0 (ADC Capture/Standard PCM Playback) via DMA"
and select "Default" this setting isn't remembered across logout/login.
Comment 3 Bug Zapper 2008-05-14 05:08:31 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Lennart Poettering 2008-06-04 08:09:01 EDT
What are you starting PA from? KDE? I think the KDE guys don't set up
module-x11-xsmp up properly, as it isn't shown in your dump. Please file a bug
for them, if you really do use KDE.

In GNOME make sure to enable the ESD checkbox to start PA on session login.
Comment 5 Lennart Poettering 2008-09-09 16:50:09 EDT

*** This bug has been marked as a duplicate of bug 448477 ***
Comment 6 Charles R. Anderson 2008-09-09 17:03:35 EDT
Sorry I didn't get back to you sooner on this.  I'm not running KDE, I'm using GNOME.  So this isn't an exact duplicate...  I'm not sure why module-x11-xsmp isn't running.  My home directory has been around with GNOME settings for many releases as the system has been upgraded or reinstalled, so perhaps something in my .gconf* settings is messed up?

How do I load the module manually?
Comment 7 Charles R. Anderson 2008-09-09 17:06:14 EDT
Ok, I figured out how to load the module, but it fails:

>pactl load-module module-x11-xsmp
Failure: Module initalization failed

>locate module-x11-xsmp
/usr/lib/pulse-0.9/modules/module-x11-xsmp.so

>rpm -qf /usr/lib/pulse-0.9/modules/module-x11-xsmp.so 
pulseaudio-module-x11-0.9.10-1.fc9.i386

>rpm -q pulseaudio pavucontrol
pulseaudio-0.9.10-1.fc9.i386
pavucontrol-0.9.6-1.fc9.i386
Comment 8 Lennart Poettering 2008-09-09 18:35:49 EDT
Reopening then.
Comment 9 Lennart Poettering 2009-02-24 20:29:43 EST
I am pretty sure that this is fixed in F10. Feel free to reopen if this problem persists.

Note You need to log in before you can comment on or make changes to this bug.